forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/open-vm-tools: bump to 10.3.5
Forces xmlsec instead of xml-security. Closes: https://bugs.gentoo.org/672318 Package-Manager: Portage-2.3.52_p8, Repoman-2.3.12_p20 Signed-off-by: Mike Gilbert <[email protected]>
- Loading branch information
Showing
2 changed files
with
156 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST open-vm-tools-10.1.10-6082533.tar.gz 5111726 BLAKE2B 22e2e901c542ae14b7537bc26ff848359f30bde6824a16968b70070dd6e57c92fbf76dca0d02e35ef45bda257725e207632b0602a4336bd2d9c97d10fb094967 SHA512 60c52a24509cb0630f2ad649fe6717fefff624fc2a5c736ced35cbdb8f639264d482e063e8140eedb39216adfb1231d58232bfef0233ebc477ba4f9a732c5965 | ||
DIST open-vm-tools-10.1.15-6677369.tar.gz 5153995 BLAKE2B 03c6b359df8f42f1ba65331dcac67e8ce86b0fce9a572c1665d3f385cae14f1757611d3948d30bb5b2e40bb2b4673bb244c45f56098faf09d6de515bb937ea3f SHA512 fe3699a7f704bdadc4c274c963d177f4700067e7436074554b7cf113ffa341ad0e4753016214f947418fd5a7cb4a6f2c0342acf074b6b414b3fd18fd2ea2bc58 | ||
DIST open-vm-tools-10.2.5-8068406.tar.gz 4818035 BLAKE2B 87e3edc42afceaf9efe69ae8cbd1abfbbf959fe09a721dbe4737ca30c6b57dcf1d8bff23bb3ed3d2236c31e7f3e6fd4d10a689b40b3b725eb580609a68bb7090 SHA512 da2f26b4b22e195af111cc16d5819aeb963f0dfa18b5d2677d897549836ec8679808315646f7f86ae36862df9e623bbcb5d553dae97a68b3ef928a5c07ea2e68 | ||
DIST open-vm-tools-10.3.5-10430147.tar.gz 4623854 BLAKE2B a2bc0ed099cd713820aea17f01131fb4ffcdefedc04b2edb217b4a96c6c9a4007f8ecc80c40445580abffaf3fb0f67be3ca9f3df7a55d368109a53da91e0db77 SHA512 2f2b3d9a8d39b01904cf845936b51a468ba61a29ca64635f842451ca9fd90bf5a770967e4c332319327c6f920ac4fb06d304e185c18ab8898aeb4fcd491a4a1f |
155 changes: 155 additions & 0 deletions
155
app-emulation/open-vm-tools/open-vm-tools-10.3.5.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,155 @@ | ||
# Copyright 1999-2018 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit autotools linux-info pam systemd toolchain-funcs user | ||
|
||
DESCRIPTION="Opensourced tools for VMware guests" | ||
HOMEPAGE="https://github.com/vmware/open-vm-tools" | ||
MY_P="${P}-10430147" | ||
SRC_URI="https://github.com/vmware/open-vm-tools/releases/download/stable-${PV}/${MY_P}.tar.gz" | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="X caf +deploypkg +dnet doc +fuse +grabbitmqproxy gtkmm +icu multimon pam +resolutionkms +ssl static-libs +vgauth" | ||
REQUIRED_USE=" | ||
multimon? ( X ) | ||
vgauth? ( ssl ) | ||
caf? ( vgauth ssl ) | ||
grabbitmqproxy? ( ssl ) | ||
" | ||
|
||
RDEPEND=" | ||
dev-libs/glib | ||
net-libs/libtirpc | ||
deploypkg? ( dev-libs/libmspack ) | ||
fuse? ( sys-fs/fuse:0 ) | ||
pam? ( virtual/pam ) | ||
ssl? ( dev-libs/openssl:0 ) | ||
vgauth? ( | ||
dev-libs/libxml2 | ||
dev-libs/xmlsec | ||
) | ||
X? ( | ||
x11-libs/libXext | ||
multimon? ( x11-libs/libXinerama ) | ||
x11-libs/libXi | ||
x11-libs/libXrender | ||
x11-libs/libXrandr | ||
x11-libs/libXtst | ||
x11-libs/libSM | ||
x11-libs/libXcomposite | ||
x11-libs/gdk-pixbuf:2 | ||
x11-libs/gtk+:3 | ||
gtkmm? ( | ||
dev-cpp/gtkmm:3.0 | ||
dev-libs/libsigc++:2 | ||
) | ||
) | ||
dnet? ( dev-libs/libdnet ) | ||
icu? ( dev-libs/icu:= ) | ||
caf? ( | ||
dev-libs/log4cpp | ||
net-libs/rabbitmq-c | ||
) | ||
resolutionkms? ( | ||
x11-libs/libdrm[video_cards_vmware] | ||
virtual/libudev | ||
) | ||
" | ||
|
||
DEPEND="${RDEPEND} | ||
net-libs/rpcsvc-proto | ||
" | ||
|
||
BDEPEND=" | ||
virtual/pkgconfig | ||
doc? ( app-doc/doxygen ) | ||
" | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/10.1.0-mount.vmhgfs.patch" | ||
"${FILESDIR}/10.1.0-Werror.patch" | ||
) | ||
|
||
pkg_setup() { | ||
local CONFIG_CHECK="~VMWARE_BALLOON ~VMWARE_PVSCSI ~VMXNET3" | ||
use X && CONFIG_CHECK+=" ~DRM_VMWGFX" | ||
kernel_is -lt 3 9 || CONFIG_CHECK+=" ~VMWARE_VMCI ~VMWARE_VMCI_VSOCKETS" | ||
kernel_is -lt 3 || CONFIG_CHECK+=" ~FUSE_FS" | ||
linux-info_pkg_setup | ||
} | ||
|
||
src_prepare() { | ||
eapply -p2 "${PATCHES[@]}" | ||
eapply_user | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
local myeconfargs=( | ||
--without-root-privileges | ||
$(use_enable multimon) | ||
$(use_with X x) | ||
$(use_with X gtk3) | ||
$(use_with gtkmm gtkmm3) | ||
$(use_enable doc docs) | ||
--disable-tests | ||
$(use_enable resolutionkms) | ||
$(use_enable static-libs static) | ||
$(use_enable deploypkg) | ||
$(use_enable grabbitmqproxy) | ||
$(use_with pam) | ||
$(use_enable vgauth) | ||
$(use_enable caf) | ||
$(use_with dnet) | ||
$(use_with icu) | ||
) | ||
# Avoid a bug in configure.ac | ||
use ssl || myeconfargs+=( --without-ssl ) | ||
|
||
econf "${myeconfargs[@]}" | ||
} | ||
|
||
src_install() { | ||
default | ||
find "${ED}" -name '*.la' -delete || die | ||
|
||
if use pam; then | ||
rm "${ED}"/etc/pam.d/vmtoolsd || die | ||
pamd_mimic_system vmtoolsd auth account | ||
fi | ||
|
||
newinitd "${FILESDIR}/open-vm-tools.initd" vmware-tools | ||
newconfd "${FILESDIR}/open-vm-tools.confd" vmware-tools | ||
|
||
if use vgauth; then | ||
systemd_newunit "${FILESDIR}"/vmtoolsd.vgauth.service vmtoolsd.service | ||
systemd_dounit "${FILESDIR}"/vgauthd.service | ||
else | ||
systemd_dounit "${FILESDIR}"/vmtoolsd.service | ||
fi | ||
|
||
# Replace mount.vmhgfs with a wrapper | ||
mv "${ED}"/usr/sbin/{mount.vmhgfs,hgfsmounter} || die | ||
dosbin "${FILESDIR}/mount.vmhgfs" | ||
|
||
# Make fstype = vmhgfs-fuse work in fstab | ||
dosym vmhgfs-fuse /usr/bin/mount.vmhgfs-fuse | ||
|
||
if use X; then | ||
fperms 4711 /usr/bin/vmware-user-suid-wrapper | ||
dobin scripts/common/vmware-xdg-detect-de | ||
|
||
elog "To be able to use the drag'n'drop feature of VMware for file" | ||
elog "exchange, please add the users to the 'vmware' group." | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
enewgroup vmware | ||
} |