Skip to content

Commit

Permalink
sys-fs/multipath-tools: Bump to version 0.7.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
Lars Wendler committed Mar 20, 2018
1 parent 43dcada commit 2fe378e
Show file tree
Hide file tree
Showing 3 changed files with 114 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/multipath-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST multipath-tools-0.5.0.tar.bz2 184024 BLAKE2B 1e1b0fdd52bf0aaea3ed281e0cd89d04aed58c03b9b42ac094173bebdf3b81e368d0c7efb23a8748d4598c99d1502fdf5f8b2c9b64a2be4ce7d6b30fa607984a SHA512 dfad21c45d0f69e39041d30d203a582c8ee8329bf390c51cde10155b3de379e7ad8fead2ac4beb268a924fd7e7dc8e1cf538ea3c70d41479fd8786fa30ba22a9
DIST multipath-tools-0.6.4.tar.gz 285448 BLAKE2B 1b63c4e712e682965c595ed988a6590e181abd4d37779b72b52f4e415d4caba33df518a1ea1e3b460d15b5a78f4db5a75c1066439eb40c503023007c1f70752a SHA512 ec35c6c26c3b233ebece7136ea99dd4c0dff2927e7b543e7091219dc7065fe87e609a1eda9ab6d08399d44fe882d70c8dbe6be9ab175d154c5dd2d12ee1d86ea
DIST multipath-tools-0.7.4.tar.gz 350361 BLAKE2B a55a5912f040913b2db8a6fe28727dd52fd4be9ceb8544f1b45384e12112775caa6159da3ce774dd529377796a2b9033490ee655f3caac864919708bdc5070ec SHA512 0a00b79920251b685265ab731e5418538f32d6392b101082c71a6c7345ef7d008bcdcf466ee1317e8bf658d0fb01fc9a2e4ec6658fc565129c1bb5949ac91254
DIST multipath-tools-0.7.5.tar.gz 367762 BLAKE2B de24d3d2b3b06638ba05465125422032044a779e8aa10d6c3aa62d2d4b12c9061c4ede7f03185ea9acb68a6f25d263362416c90076e8c1c1aa3ef8db3045fbdc SHA512 4808d0cea08558ba6c24ee4d12e1caf67603b124044e5c38a10471fb52b0e3ed898c4ca0f1ec01373fc316cd999277da47698968db2b352890c002bbf9e76746
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
--- multipath-tools-0.7.5/Makefile.inc
+++ multipath-tools-0.7.5/Makefile.inc
@@ -91,12 +91,13 @@
-Wp,-D_FORTIFY_SOURCE=2 $(STACKPROT) \
--param=ssp-buffer-size=4

-CFLAGS := $(OPTFLAGS) -DBIN_DIR=\"$(bindir)\" -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\" \
- -MMD -MP $(CFLAGS)
+CFLAGS ?= $(OPTFLAGS)
+CFLAGS += -DBIN_DIR=\"$(bindir)\" -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\" \
+ -MMD -MP
BIN_CFLAGS = -fPIE -DPIE
LIB_CFLAGS = -fPIC
SHARED_FLAGS = -shared
-LDFLAGS = -Wl,-z,relro -Wl,-z,now
+LDFLAGS += -Wl,-z,relro -Wl,-z,now
BIN_LDFLAGS = -pie

# Check whether a function with name $1 has been declared in header file $2.
94 changes: 94 additions & 0 deletions sys-fs/multipath-tools/multipath-tools-0.7.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit linux-info systemd toolchain-funcs udev vcs-snapshot toolchain-funcs

DESCRIPTION="Device mapper target autoconfig"
HOMEPAGE="http://christophe.varoqui.free.fr/"
SRC_URI="https://git.opensvc.com/?p=multipath-tools/.git;a=snapshot;h=${PV};sf=tgz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="systemd rbd"

RDEPEND="
dev-libs/json-c:=
dev-libs/libaio
dev-libs/userspace-rcu
>=sys-fs/lvm2-2.02.45
>=virtual/udev-171
sys-libs/readline:0=
rbd? ( sys-cluster/ceph )
systemd? ( sys-apps/systemd )
"
DEPEND="
${RDEPEND}
virtual/pkgconfig
"

CONFIG_CHECK="~DM_MULTIPATH"

RESTRICT="test"

PATCHES=( "${FILESDIR}"/${PN}-0.7.5-respect-flags.patch )

get_systemd_pv() {
use systemd && \
$(tc-getPKG_CONFIG) --modversion systemd
}

pkg_pretend() {
linux-info_pkg_setup
}

pkg_setup() {
linux-info_pkg_setup
}

src_prepare() {
default

# The upstream lacks any way to configure the build at present
# and ceph is a huge dependency, so we're using sed to make it
# optional until the upstream has a proper configure system
if ! use rbd ; then
sed \
-e "s/libcheckrbd.so/# libcheckrbd.so/" \
-e "s/-lrados//" \
-i libmultipath/checkers/Makefile \
|| die
fi
}

src_compile() {
# LIBDM_API_FLUSH involves grepping files in /usr/include,
# so force the test to go the way we want #411337.
emake \
CC="$(tc-getCC)" \
LIBDM_API_FLUSH=1 SYSTEMD="$(get_systemd_pv)"
}

src_install() {
dodir /sbin /usr/share/man/man{5,8}
emake \
DESTDIR="${D}" \
SYSTEMD=$(get_systemd_pv) \
unitdir="$(systemd_get_systemunitdir)" \
libudevdir='${prefix}'/"$(get_udevdir)" \
install

newinitd "${FILESDIR}"/rc-multipathd multipathd
newinitd "${FILESDIR}"/multipath.rc multipath

einstalldocs
}

pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "If you need multipath on your system, you must"
elog "add 'multipath' into your boot runlevel!"
fi
}

0 comments on commit 2fe378e

Please sign in to comment.