Skip to content

Commit

Permalink
dev-python/aiohttp-socks: Add testing code, correct deps, EAPI 7
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jul 30, 2019
1 parent 25e7276 commit 300155f
Showing 1 changed file with 20 additions and 6 deletions.
26 changes: 20 additions & 6 deletions dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

PYTHON_COMPAT=( python3_{6,7} )

Expand All @@ -14,10 +14,24 @@ SRC_URI="https://github.com/romis2012/aiohttp-socks/archive/${PV}.tar.gz -> ${P}
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
IUSE="test"
# Tests require Internet access
RESTRICT="test"

RDEPEND="
>=dev-python/aiohttp-2.3.2[${PYTHON_USEDEP}]
"
RDEPEND=">=dev-python/aiohttp-2.3.2[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
net-proxy/3proxy
)"

DOCS=( README.md )
python_configure_all() {
rm tests/3proxy/bin/*/* || die
ln -s "$(type -P 3proxy)" tests/3proxy/bin/linux/ || die
}

python_test() {
pytest -vv || die "Tests fail with ${EPYTHON}"
}

0 comments on commit 300155f

Please sign in to comment.