Skip to content

Commit

Permalink
dev-haskell/pipes: new package
Browse files Browse the repository at this point in the history
"Compositional pipelines", a depend of app-emacs/ghc-mod

Bug: https://bugs.gentoo.org/show_bug.cgi?id=476352
Package-Manager: portage-2.2.23
  • Loading branch information
Sergei Trofimovich committed Oct 22, 2015
1 parent 30116e1 commit 300667c
Show file tree
Hide file tree
Showing 3 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-haskell/pipes/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST pipes-4.1.6.tar.gz 38387 SHA256 2d6a5060380497a16287d156c69cbd55d2d3efc6d57d5079f794f90c944e7435 SHA512 a5467658ad9e60b8d2ba39fe4c8fca228388484e9a534e284b51069abc3a7f61382d0cdd6277fa99d5295af06d05496cd2cf4acbdec7cc1556de870d6b0abedd WHIRLPOOL afec914749e101feda0c5d32f405fb3a6e69917048524dfd6e4e22a22e5bd864a016995881774032d2d1d05b1c283da78aa7362be7d1f5d0be53fd45c57a4dc4
32 changes: 32 additions & 0 deletions dev-haskell/pipes/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>haskell</herd>
<longdescription>
\&quot;Coroutines done right\&quot;. This library generalizes iteratees and coroutines
simply and elegantly.

Advantages over traditional iteratee\/coroutine implementations:

* /Concise API/: Use three simple commands: (&#39;&gt;-&gt;&#39;), &#39;request&#39;, and &#39;respond&#39;

* /Bidirectionality/: Implement duplex channels

* /Blazing fast/: Implementation tuned for speed

* /Elegant semantics/: Use practical category theory

* /Extension Framework/: Mix and match extensions and create your own

* /ListT/: Correct implementation of ListT that interconverts with pipes

* /Lightweight Dependency/: @pipes@ depends only on @transformers@ and
@mmorph@ and compiles rapidly

* /Extensive Documentation/: Second to none!

Import &quot;Control.Proxy&quot; to use the library.

Read &quot;Control.Proxy.Tutorial&quot; for an extensive tutorial.
</longdescription>
</pkgmetadata>
31 changes: 31 additions & 0 deletions dev-haskell/pipes/pipes-4.1.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

# ebuild generated by hackport 0.4.5.9999

CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal

DESCRIPTION="Compositional pipelines"
HOMEPAGE="http://hackage.haskell.org/package/pipes"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND=">=dev-haskell/mmorph-1.0.0:=[profile?] <dev-haskell/mmorph-1.1:=[profile?]
>=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
>=dev-haskell/transformers-0.2.0.0:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
test? ( >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-3
>=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-1
>=dev-haskell/test-framework-quickcheck2-0.2.0 <dev-haskell/test-framework-quickcheck2-0.4 )
"

0 comments on commit 300667c

Please sign in to comment.