Skip to content

Commit

Permalink
dev-util/promu: Update snapshot
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
mrueg committed Feb 7, 2017
1 parent a59dd48 commit 300b5c6
Show file tree
Hide file tree
Showing 2 changed files with 31 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/promu/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST promu-0.1.0_p20161031.tar.gz 393908 SHA256 eab458c5f03dd45405ef56b1e333bd95fdd379d6a3010af1a2a0fc9db2d49159 SHA512 75bb77f91bb4ee2817e0481e13e0ac0c4abe4ab899608a455fac99e9939f63eedd17e42271c1ac76f2d475fb5aaa066dd24d5229b3e74571eec67dd448c7a487 WHIRLPOOL 67988a4980c908650001f423a3683486520a1b1d61389bdc2c423b90d3c097fad7066e8e0096b4d85ce0d1edc83c6813a5c94414a1b9c2cc4edecfe05b61316c
DIST promu-0.1.0_p20170130.tar.gz 393885 SHA256 a8807488ff74bb6ad9653ffa91accdbbf11382dfa8e5ca511f086f7a52f785fa SHA512 fd12a1f96ab55bfd669e912b68902e9340726da6f70d95159f055006bbbbe8e0cc14e9878b4dda3f473f9521918d6033d98e713b4d18d66dae03b1fa25828a80 WHIRLPOOL 21543bb1e9706bfdbe11c07dbb5fefcd0dbb7626baf7a59bb128d3f4ee58a1d71ff0b402ad1b7dc832dc8acb461578c680e0fb4a6f99cc834678575076076851
30 changes: 30 additions & 0 deletions dev-util/promu/promu-0.1.0_p20170130.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit golang-build golang-vcs-snapshot

EGO_PN="github.com/prometheus/promu/..."
EGIT_COMMIT="8a62dcf16adcf41f855ebb1a3c883fb61de1d030"
ARCHIVE_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Prometheus Utility Tool"
HOMEPAGE="https://github.com/prometheus/promu"
SRC_URI="${ARCHIVE_URI}"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

src_compile() {
LDFLAGS="-X github.com/prometheus/vendor/github.com/prometheus/common/version.Version=$(cat src/${EGO_PN%/*}/VERSION)
-X github.com/prometheus/vendor/github.com/prometheus/common/version.Revision=${EGIT_COMMIT:0:7}
-extldflags \"-static\""
GOPATH="${S}" go build -ldflags "${LDFLAGS}" -o bin/promu src/${EGO_PN%/*}/main.go || die
}

src_install() {
dobin bin/*
dodoc -r src/${EGO_PN%/*}/{doc,{README,CONTRIBUTING}.md}
}

0 comments on commit 300b5c6

Please sign in to comment.