Skip to content

Commit

Permalink
sys-libs/musl: version bump to 1.1.14
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
blueness committed Feb 22, 2016
1 parent 0cf50bc commit 301007e
Show file tree
Hide file tree
Showing 2 changed files with 132 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-libs/musl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST musl-1.1.12.tar.gz 918757 SHA256 720b83c7e276b4b679c0bffe9509340d5f81fd601508e607e708177df0d31c0e SHA512 7cabbe2665e32bd3408c8865f89f474106e982b4e5de81d0cdeea19e19e20b4d2496faf1adc6b2811d996f30f39258184ba347e8eb5f3811eab89179e8f52d70 WHIRLPOOL cd500c3457be42d8dd927420d2352bda87e7b424fabf19fbd387858b913636793a7ff8d0e249bcc292e58c6d0d3889738c8790f3a6409d6df2da81408a77238c
DIST musl-1.1.14.tar.gz 894971 SHA256 35f6c00c84a6091bd5dab29eedde7508dae755ead92dcc0239f3677d1055b9b5 SHA512 9016246b44a7e6ef51477f0a246373c79f3e796c70031c3323be1b6c4c0518a2d4578f1aa712adfd9a80cdc1d71918bd7a35855052a0452b854755bf0cc2424e WHIRLPOOL e675ed13888021376812c65addf245906bfca00c5291ca5979cb4894cbe72b3a1b69c0fd793bd49f9cef2154131f717b15b52398b43c68fcfb7c5530b1258e72
131 changes: 131 additions & 0 deletions sys-libs/musl/musl-1.1.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,131 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils flag-o-matic multilib toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.musl-libc.org/musl"
inherit git-r3
fi

export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
export CTARGET=${CATEGORY#cross-}
fi
fi

DESCRIPTION="Light, fast and simple C library focused on standards-conformance and safety"
HOMEPAGE="http://www.musl-libc.org/"
if [[ ${PV} != "9999" ]] ; then
PATCH_VER=""
SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
KEYWORDS="-* ~amd64 ~arm ~mips ~ppc ~x86"
fi

LICENSE="MIT LGPL-2 GPL-2"
SLOT="0"
IUSE="crosscompile_opts_headers-only"

RDEPEND="!sys-apps/getent"

QA_SONAME="/usr/lib/libc.so"
QA_DT_NEEDED="/usr/lib/libc.so"

is_crosscompile() {
[[ ${CHOST} != ${CTARGET} ]]
}

just_headers() {
use crosscompile_opts_headers-only && is_crosscompile
}

musl_endian() {
# XXX: this wont work for bi-endian, but we dont have any
touch "${T}"/endian.s || die
$(tc-getAS ${CTARGET}) "${T}"/endian.s -o "${T}"/endian.o
case $(file "${T}"/endian.o) in
*" MSB "*) echo "";;
*" LSB "*) echo "el";;
*) echo "nfc";; # We shouldn't be here
esac
}

pkg_setup() {
if [ ${CTARGET} == ${CHOST} ] ; then
case ${CHOST} in
*-musl*) ;;
*) die "Use sys-devel/crossdev to build a musl toolchain" ;;
esac
fi
}

src_prepare() {
epatch_user
}

src_configure() {
tc-getCC ${CTARGET}
just_headers && export CC=true

local sysroot
is_crosscompile && sysroot=/usr/${CTARGET}
./configure \
--target=${CTARGET} \
--prefix=${sysroot}/usr \
--syslibdir=${sysroot}/lib \
--disable-gcc-wrapper
}

src_compile() {
emake obj/include/bits/alltypes.h
just_headers && return 0

emake
}

src_install() {
local target="install"
just_headers && target="install-headers"
emake DESTDIR="${D}" ${target}
just_headers && return 0

# musl provides ldd via a sym link to its ld.so
local sysroot
is_crosscompile && sysroot=/usr/${CTARGET}
local ldso=$(basename "${D}"${sysroot}/lib/ld-musl-*)
dosym ${sysroot}/lib/${ldso} ${sysroot}/usr/bin/ldd

if [[ ${CATEGORY} != cross-* ]] ; then
local target=$(tc-arch) arch
local endian=$(musl_endian)
case ${target} in
amd64) arch="x86_64";;
arm) arch="armhf";; # We only have hardfloat right now
mips) arch="mips${endian}";;
ppc) arch="powerpc";;
x86) arch="i386";;
esac
cp "${FILESDIR}"/ldconfig.in "${T}" || die
sed -e "s|@@ARCH@@|${arch}|" "${T}"/ldconfig.in > "${T}"/ldconfig || die
into /
dosbin "${T}"/ldconfig
into /usr
dobin "${FILESDIR}"/getent
echo 'LDPATH="include ld.so.conf.d/*.conf"' > "${T}"/00musl || die
doenvd "${T}"/00musl || die
fi
}

pkg_postinst() {
is_crosscompile && return 0

[ "${ROOT}" != "/" ] && return 0

ldconfig
# reload init ...
/sbin/telinit U 2>/dev/null
}

0 comments on commit 301007e

Please sign in to comment.