forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-perl/Parallel-ForkManager: Version bump
Package-Manager: portage-2.2.28
- Loading branch information
1 parent
4eef81a
commit 3019f75
Showing
2 changed files
with
40 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST Parallel-ForkManager-1.02.tar.gz 13270 SHA256 fb005d9a25b9bab86244673deaeefc18e83c590dd2b9b74ef53d21134c981534 SHA512 a5efaf348939019494dc5c7bb56c817ffab09782907de80f0258ef75a4639e56919bb35608321a17aa9322c838def4eb789f2e4dc56ad44825a4b2997b798ed7 WHIRLPOOL 800bb5bd36d078c30fe594405011bfe10fb528c3f87dd15a87b82df1f9b76c31f2f5d58ed6d934a6fe1fbaa90595c44756704ed1b655de622ecbe420fcf9ba23 | ||
DIST Parallel-ForkManager-1.17.tar.gz 23121 SHA256 a929002658b9b4944a4511e24ee6cda05d24c2a3ba54a5ce13e0b3fdf74bf0aa SHA512 2897cc737bc35ab88bd60fea1cd371a499ea32fdcc33095601ecf8930725dd6350041172dd138e4ee4a529641aacb6fa51ae34f7ac9f1359f910713f3afa0f2c WHIRLPOOL 1bdaabbf593fcccb86b89046f9b35fa5b11406fe7c0637fbf7329cf5cd9f89e9ad427a1d8cf44033c0345279c7f299828e7476f6b06fa92c5a640eacb6bb37a8 |
39 changes: 39 additions & 0 deletions
39
dev-perl/Parallel-ForkManager/Parallel-ForkManager-1.170.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
DIST_AUTHOR=YANICK | ||
DIST_VERSION=1.17 | ||
inherit perl-module | ||
|
||
DESCRIPTION="A simple parallel processing fork manager" | ||
|
||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~sparc-solaris ~x86-solaris" | ||
IUSE="test minimal examples" | ||
|
||
RDEPEND=" | ||
virtual/perl-Carp | ||
virtual/perl-File-Path | ||
virtual/perl-File-Temp | ||
virtual/perl-Storable | ||
" | ||
DEPEND="${RDEPEND} | ||
virtual/perl-ExtUtils-MakeMaker | ||
test? ( | ||
!minimal? ( >=virtual/perl-CPAN-Meta-2.120.900 ) | ||
virtual/perl-IO | ||
>=virtual/perl-Test-Simple-0.940.0 | ||
dev-perl/Test-Warn | ||
) | ||
" | ||
src_install() { | ||
perl-module_src_install | ||
if use examples; then | ||
docompress -x /usr/share/doc/${PF}/examples | ||
insinto /usr/share/doc/${PF}/examples | ||
doins -r examples/* | ||
fi | ||
} |