Skip to content

Commit

Permalink
sys-apps/elfix: version bump 0.9.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
blueness committed Sep 4, 2015
1 parent c7c8c91 commit 30368ff
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-apps/elfix/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST elfix-0.8.4.tar.gz 374742 SHA256 374be66da3dddef485bbb5e95bfcab6fd0c2db478255bddd10079730ada5260b SHA512 10aacc3fff33c934e2d4487d174a2b0cec10ffb7a35fc72b160c786f82f0355f3a2dea716bc7fb929d2919cc32a26844f37f9d73064b755098bdaa72e8075bda WHIRLPOOL b04e099f188c0b76d8c07abd76559c1313854aa83a03ad69afb72674d93cde6ce538ae10d0fea3be5495937e72a4b98fdd36efbb2e3aa8ff23c1d9f7f943c1ae
DIST elfix-0.9.0.tar.gz 372014 SHA256 8b547d987edb2f7dc23ddf30f959d7d051a9ed49810f983b8fe6c489fe731cf0 SHA512 fd9bab90d745f77429c902acd2a14f615132731b3c38929dce764f1e5f7ee8f6478a6fef7ce0cb38e7ebd9181ba57965ff0c97da5e01d0fbf2cfb940ed691ebf WHIRLPOOL c09fa2193b990a506cae17f370ec10fa6302e17d2a165e42eceb88644f8a92e297c839ad788204e213d8205695b65557a7dcef5f6417177c434c8d0a34bd5eb7
DIST elfix-0.9.1.tar.gz 398588 SHA256 0368d07bfdad4a14f039929a30d85a612dcd9d22ac87211f8e59d452bac23625 SHA512 28fdde7841263cee766434b5eda1a4151999526aa3a1acaacd2e6355502df4b56db9faf64ce81bdc89606d366d0a6dd28c5c135290fe7f0285cee480f6002527 WHIRLPOOL cd7dc6e191d97836f4b8859b73777e3b4b6fce5d290087400327f87a621e9879f5c233eef51bef981398d0d00ecc753f222655108994d25a4e0503799569ec82
50 changes: 50 additions & 0 deletions sys-apps/elfix/elfix-0.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

inherit eutils

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
inherit git-2
else
SRC_URI="https://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
fi

DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo"
HOMEPAGE="https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
https://dev.gentoo.org/~blueness/elfix/"

LICENSE="GPL-3"
SLOT="0"
IUSE="+ptpax +xtpax"

REQUIRED_USE="|| ( ptpax xtpax )"

# These only work with a properly configured PaX kernel
RESTRICT="test"

DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
ptpax? ( dev-libs/elfutils )
xtpax? ( sys-apps/attr )"

RDEPEND="${DEPEND}"

src_prepare() {
[[ ${PV} == "9999" ]] && ./autogen.sh
}

src_configure() {
rm -f "${S}/scripts/setup.py"
econf --disable-tests \
$(use_enable ptpax) \
$(use_enable xtpax)
}

src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
}

0 comments on commit 30368ff

Please sign in to comment.