Skip to content

Commit

Permalink
app-metrics/memcached_exporter: 0.6.0 bump
Browse files Browse the repository at this point in the history
Signed-off-by: William Hubbs <[email protected]>
  • Loading branch information
williamh committed Jul 5, 2020
1 parent 455ef7e commit 304988c
Show file tree
Hide file tree
Showing 2 changed files with 35 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-metrics/memcached_exporter/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST memcached_exporter-0.5.0.tar.gz 1350752 BLAKE2B e9a326ca155e0e0a89dd556f0a97ba9bbe73e3e02a905497c55a5390be2cbf211dde9dda37355dd043b711258c78cf911c79ae898b6e0934f2d4b2ddef7ae946 SHA512 62ec7f9cefc88425ea3b53a634b2d5ff1534624b6e149c962372e81a7271fc1bf3c01c7d8641dc49250b8d124bec740b3c2768e62d51cfdc025a29f71a49b428
DIST memcached_exporter-0.6.0.tar.gz 1709929 BLAKE2B 3b2f3272289d7745b560eb466918c00a2b65947dfcc219d2971cf6215a5590809c48e4b4385e572ff38c1abe7af74c9bf1575450498382b18644a46d1dab3dd7 SHA512 02238da4e901c3e3b57144501d64fa19502bdcf1aa65e775188ef18f9e524c4e2a44d87e8dcc926261b589715a8347628b87c2e418bcbcc63b5a18058ef771be
34 changes: 34 additions & 0 deletions app-metrics/memcached_exporter/memcached_exporter-0.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit go-module user

DESCRIPTION="Prometheus exporter for memcached"
HOMEPAGE="https://github.com/prometheus/memcached_exporter"
SRC_URI="https://github.com/prometheus/memcached_exporter/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS="~amd64"

BDEPEND="dev-util/promu"

pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 -1 ${PN}
}

src_compile() {
mkdir bin || die
promu build --prefix bin || die
}

src_install() {
newbin bin/${P} ${PN}
dodoc *.md
keepdir /var/log/${PN}
fowners ${PN}:${PN} /var/log/${PN}
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
}

0 comments on commit 304988c

Please sign in to comment.