Skip to content

Commit

Permalink
app-vim/languagetool: initial import
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Sep 24, 2016
1 parent 8d1f2f2 commit 305326a
Show file tree
Hide file tree
Showing 4 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-vim/languagetool/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST languagetool-1.29.tar.bz2 8059 SHA256 92fd4bf94c65828f1c309da5257336a2287c07cae7ab6a4709ae1b79dcbbbcca SHA512 09b5bdc1d3590afe26578f687064a7a62493a11fafca903759dc1e9048cb22a04c6352127b13e4a63acb867d73d943b56fcae7f733350626f05b66a6d1f1626d WHIRLPOOL d5c8d411b465fdad629493e834d154e7e3a25898b20bc009c4ff9977593ab46ca6e0f6f57ae7933da08b9f7283ebc793106a4eb31a17d670050a94f27a2f2af5
38 changes: 38 additions & 0 deletions app-vim/languagetool/files/languagetool-1.29-script.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
Use launcher script instead of directly running from the jar file.

--- languagetool-1.29/plugin/LanguageTool.vim
+++ languagetool-1.29/plugin/LanguageTool.vim
@@ -162,23 +162,6 @@
endif
endif
endif
-
- let s:languagetool_jar = exists("g:languagetool_jar")
- \ ? g:languagetool_jar
- \ : $HOME . '/languagetool/languagetool-commandline.jar'
-
- if !filereadable(s:languagetool_jar)
- " Hmmm, can't find the jar file. Try again with expand() in case user
- " set it up as: let g:languagetool_jar = '$HOME/languagetool-commandline.jar'
- let l:languagetool_jar = expand(s:languagetool_jar)
- if !filereadable(expand(l:languagetool_jar))
- echomsg "LanguageTool cannot be found at: " . s:languagetool_jar
- echomsg "You need to install LanguageTool and/or set up g:languagetool_jar"
- echomsg "to indicate the location of the languagetool-commandline.jar file."
- return -1
- endif
- let s:languagetool_jar = l:languagetool_jar
- endif
return 0
endfunction

@@ -242,8 +225,7 @@
let l:range = a:line1 . ',' . a:line2
silent exe l:range . 'w!' . l:tmpfilename

- let l:languagetool_cmd = 'java'
- \ . ' -jar ' . s:languagetool_jar
+ let l:languagetool_cmd = 'languagetool'
\ . ' -c ' . s:languagetool_encoding
\ . (empty(s:languagetool_disable_rules) ? '' : ' -d '.s:languagetool_disable_rules)
\ . ' -l ' . s:languagetool_lang
18 changes: 18 additions & 0 deletions app-vim/languagetool/languagetool-1.29.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit vim-plugin eutils

MY_PN=LanguageTool
DESCRIPTION="grammar checker for various languages"
HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3223"
LICENSE="vim"
KEYWORDS="~amd64 ~x86"

VIM_PLUGIN_HELPFILES="${MY_PN}"

RDEPEND="app-text/languagetool"

PATCHES=( "${FILESDIR}"/${P}-script.patch )
8 changes: 8 additions & 0 deletions app-vim/languagetool/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Vim Project</name>
</maintainer>
</pkgmetadata>

0 comments on commit 305326a

Please sign in to comment.