Skip to content

Commit

Permalink
dev-ros/ament_lint_auto: use python_has_version inside python_check_deps
Browse files Browse the repository at this point in the history
Signed-off-by: Arthur Zamarin <[email protected]>
  • Loading branch information
arthurzam committed Oct 4, 2022
1 parent d7b1498 commit 308c74e
Show file tree
Hide file tree
Showing 3 changed files with 11 additions and 14 deletions.
9 changes: 4 additions & 5 deletions dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2019-2021 Gentoo Authors
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand Down Expand Up @@ -30,14 +30,13 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
BDEPEND="
BDEPEND="${PYTHON_DEPS}
$(python_gen_any_dep '
dev-python/ament_package[${PYTHON_USEDEP}]
dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"

python_check_deps() {
has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
"dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}
7 changes: 3 additions & 4 deletions dev-ros/ament_lint_auto/ament_lint_auto-0.12.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -30,14 +30,13 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
BDEPEND="
BDEPEND="${PYTHON_DEPS}
$(python_gen_any_dep '
dev-python/ament_package[${PYTHON_USEDEP}]
dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"

python_check_deps() {
has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
"dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}
9 changes: 4 additions & 5 deletions dev-ros/ament_lint_auto/ament_lint_auto-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2019-2021 Gentoo Authors
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand Down Expand Up @@ -30,14 +30,13 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
BDEPEND="
BDEPEND="${PYTHON_DEPS}
$(python_gen_any_dep '
dev-python/ament_package[${PYTHON_USEDEP}]
dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"

python_check_deps() {
has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
"dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}

0 comments on commit 308c74e

Please sign in to comment.