Skip to content

Commit

Permalink
app-emulation/86Box: add 4.1
Browse files Browse the repository at this point in the history
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Mar 9, 2024
1 parent 20908fe commit 30b179a
Show file tree
Hide file tree
Showing 2 changed files with 85 additions and 0 deletions.
84 changes: 84 additions & 0 deletions app-emulation/86Box/86Box-4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,84 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake flag-o-matic

DESCRIPTION="Emulator of x86-based machines based on PCem"
HOMEPAGE="https://github.com/86Box/86Box"
SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="dinput experimental +fluidsynth +munt new-dynarec +openal qt5 +qt6 +threads"

DEPEND="
app-emulation/faudio
dev-libs/libevdev
media-libs/freetype:2=
media-libs/libpng:=
media-libs/libsdl2
media-libs/openal
media-libs/rtmidi
net-libs/libslirp
sys-libs/zlib
qt5? ( x11-libs/libXi )
qt6? ( x11-libs/libXi )
"

RDEPEND="
${DEPEND}
fluidsynth? ( media-sound/fluidsynth )
munt? ( media-libs/munt-mt32emu )
openal? ( media-libs/openal )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtopengl:5
dev-qt/qttranslations:5
dev-qt/qtwidgets:5
kde-frameworks/extra-cmake-modules
)
qt6? (
dev-qt/qtbase:6[gui,network,opengl,widgets]
dev-qt/qttranslations:6
kde-frameworks/extra-cmake-modules
)
"

BDEPEND="virtual/pkgconfig"

src_configure() {
# LTO needs to be filtered
# See https://bugs.gentoo.org/854507
filter-lto
append-flags -fno-strict-aliasing

local mycmakeargs=(
-DCPPTHREADS="$(usex threads)"
-DDEV_BRANCH="$(usex experimental)"
-DDINPUT="$(usex dinput)"
-DDYNAREC="ON"
-DMUNT_EXTERNAL="$(usex munt)"
-DFLUIDSYNTH="$(usex fluidsynth)"
-DMINITRACE="OFF"
-DMUNT="$(usex munt)"
-DNEW_DYNAREC="$(usex new-dynarec)"
-DOPENAL="$(usex openal)"
-DPREFER_STATIC="OFF"
-DRTMIDI="ON"
-DQT="$(usex qt5 'ON' $(usex qt6))"
-DRELEASE="ON"
-DUSE_QT6="$(usex qt6)"
)

cmake_src_configure
}

pkg_postinst() {
elog "In order to use 86Box, you will need some roms for various emulated systems."
elog "See https://github.com/86Box/roms for more information."
}
1 change: 1 addition & 0 deletions app-emulation/86Box/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST 86Box-4.0.1.tar.gz 5206128 BLAKE2B 56a4d374757eb67368bbc5782bceca3f4dec79dd36fad6698065a86c3937238b352425dd856169a1a65a42a4f60f1a68b099ece4a7c019be4229d61fabfc444a SHA512 b06a8c50558276f35f98795e0513b5bd39eed3a0d3a8d61bf79b373501cd823ab3ab12fb943e879a240292bca39c507a1a42b1b6f3f9ae596499b685a03acf98
DIST 86Box-4.1.tar.gz 5367654 BLAKE2B d7bbe2ba203a866d6be3ebbc64531da38eb820cfb313837acb0ddf6bc6e93b25501bea1eb3c4a4f61f2383590ac35b7525c3643da6b9d246ae6e73e04e928f5f SHA512 bfc1267b333dd738e5935b0c6b9eec3d84863bda22ba52d4d51e59e72f6bcaa78b6e9c656699eef3c3e436072b18c32d11f8d57a5bb578fc0334430fbdb48b35

0 comments on commit 30b179a

Please sign in to comment.