Skip to content

Commit

Permalink
app-admin/ansible: 2.5.1 bup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.27, Repoman-2.3.9
  • Loading branch information
prometheanfire committed Apr 19, 2018
1 parent 858ab83 commit 30b4d5c
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/ansible/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST ansible-2.4.2.0.tar.gz 6503595 BLAKE2B df4ec4e24671f1488950f2d9eb7705fbad4e
DIST ansible-2.4.3.0.tar.gz 6511115 BLAKE2B d43679c651f6aa5fd86c797a204645a8ee98efbcde9abaa25385aeb6f1d7c8b4ad74185434bfd159dbf673fe9339ef8f915f78238f8b8a5caf924b54cb9bdd52 SHA512 a7cda358c67c519c7e5ba248bf47070f21a27203fb29d70d9d75ecf027ba1275d71c0f96493e047281211d172a3be8273d7e08144446284695fb0bc8b94daa82
DIST ansible-2.4.4.0.tar.gz 6512938 BLAKE2B 51e397d2242209271a8aef211c3bdeb34a15e2061a202415749ecb4232e0521aff304d5585d536b1805f14ff476b0733d559eeabe6e44de7b273b8606b11b805 SHA512 f0dcf92f2c69931fa06e6dd3845c11592d5a7e44f19a99c4d6c361022708560170f2b74ad20eded61fa5812c90eed281b78396aa92e0b33717970afb5966dd72
DIST ansible-2.5.0.tar.gz 10073927 BLAKE2B 00e5d4245b7ea89a3826a3ab25c880c3acfdb713a045b9583dcc7fe913673954f1bee31d10a5125a8c386eca8d478ca807e44466a4c2729cfb571323836d5353 SHA512 93dee0404c5de0a9c8c5b8987f1fb2dbacceb848e8d5b4c70c5a6692d6fe8e9d4bec67d592071346f458b46b9ed2d800609a080d7d4b16266943f32d56a19220
DIST ansible-2.5.1.tar.gz 10100358 BLAKE2B 39831c6ed49360e905ac8fb8d9ad7520c0bc16b5dbe19103c5349cb5d6fe30c2c3212f08f15a7877692b2a9a2ca3e1ab8e5580bc9919f7c2d96f7b07ae45f1e2 SHA512 d5ed9ba4bb514b79254a79a89d1572e80c5cfb1db2a67a980184aa3c26ff407f5c5c9bd0efa24f0e00af451d955f3b0d8d9ad3026be71ba7ad12487a1631ad9a
56 changes: 56 additions & 0 deletions app-admin/ansible/ansible-2.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{5,6} )

inherit distutils-r1 eutils versionator

DESCRIPTION="Model-driven deployment, config management, and command execution framework"
HOMEPAGE="https://ansible.com/"
SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x64-macos"
IUSE="test"

RDEPEND="
dev-python/paramiko[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/cryptography[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/netaddr[${PYTHON_USEDEP}]
net-misc/sshpass
virtual/ssh
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/packaging-16.6[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
dev-python/passlib[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/unittest2[${PYTHON_USEDEP}]
dev-vcs/git
)"

# not included in release tarball
RESTRICT="test"

python_test() {
nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
}

python_install_all() {
distutils-r1_python_install_all

doman docs/man/man1/*.1
dodoc -r examples
}

0 comments on commit 30b4d5c

Please sign in to comment.