forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-video/get_flash_videos: Bump to 1.25.94
Closes: https://bugs.gentoo.org/623598 Signed-off-by: Pacho Ramos <[email protected]> Package-Manager: Portage-2.3.51, Repoman-2.3.11
- Loading branch information
Showing
2 changed files
with
57 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST get_flash_videos-1.24.tar.gz 86380 BLAKE2B 6a391a3e9c31cbedb76dc0846a601af6c0ad730e1b81bcadab1d1efca80fb87c1bbd0310da962076fd5d166e2d776a77edcfa8ee1076fddf508518bcdd7053f2 SHA512 b966adc381ddf096f9f57ddd3ce0a9a155b3850f345b0624f11b4c553036f1e8881cf7c70e4f789741a43263325e35653f005731563702b6d7a594530558fc48 | ||
DIST get_flash_videos-1.25.94.tar.gz 136922 BLAKE2B c353fd5396a6dcd0a759538d16d8237a1f137308d2cc2bbacdd78f6adfc7542b9603d0b63f7d94203dda2611d4972d8d8699aa64863175d7c8cbb148a622c9d3 SHA512 f7ec42e763aa83d8aaa5ac0481785ef6197f0f34ff3b3b2209e63767eb8116d5fb75f85732fa37c7e56729bc83b7d4d57dcf5cab954d9f439d21ad00badbdacf |
56 changes: 56 additions & 0 deletions
56
media-video/get_flash_videos/get_flash_videos-1.25.94.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,56 @@ | ||
# Copyright 1999-2018 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit perl-module readme.gentoo-r1 | ||
|
||
DESCRIPTION="Downloads videos from various Flash-based video hosting sites" | ||
HOMEPAGE="https://github.com/monsieurvideo/get-flash-videos" | ||
SRC_URI="https://github.com/monsieurvideo/get-flash-videos/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="test" | ||
#RESTRICT="test" # Fail to work for a long time, bug #407381 | ||
|
||
RDEPEND=" | ||
dev-perl/HTML-TokeParser-Simple | ||
dev-perl/Module-Find | ||
dev-perl/Term-ProgressBar | ||
dev-perl/WWW-Mechanize | ||
virtual/perl-Module-CoreList | ||
" | ||
DEPEND="${RDEPEND} | ||
dev-perl/UNIVERSAL-require | ||
test? ( media-video/rtmpdump | ||
dev-perl/Tie-IxHash | ||
dev-perl/XML-Simple | ||
dev-perl/Crypt-Rijndael | ||
dev-perl/Data-AMF | ||
virtual/perl-IO-Compress ) | ||
" | ||
|
||
S="${WORKDIR}/${P//_/-}" | ||
|
||
SRC_TEST="do" | ||
myinst="DESTDIR=${D}" | ||
|
||
DISABLE_AUTOFORMATTING="yes" | ||
DOC_CONTENTS="Downloading videos from RTMP server requires the following packages: | ||
- media-video/rtmpdump | ||
- dev-perl/Tie-IxHash | ||
Other optional dependencies: | ||
- dev-perl/XML-Simple | ||
- dev-perl/Crypt-Rijndael | ||
- dev-perl/Data-AMF | ||
- virtual/perl-IO-Compress" | ||
|
||
src_install() { | ||
perl-module_src_install | ||
readme.gentoo_create_doc | ||
} | ||
|
||
pkg_postinst() { | ||
readme.gentoo_print_elog | ||
} |