Skip to content

Commit

Permalink
sci-electronics/gazebo: Bump to 8.1.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
aballier committed May 7, 2017
1 parent b3f9a9a commit 312e3cf
Show file tree
Hide file tree
Showing 2 changed files with 78 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-electronics/gazebo/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gazebo-8.0.0.tar.bz2 52472089 SHA256 ea733be6946ac5c538bf207ba01f3a6d6afa456d0b70455f7066b19d722f0d12 SHA512 51890faebe50112fcdc4f53cb8e7be583f62e9690ffdfab1bc2346a79157a7e796830f58f64573c3fbe1caa7653b2fb0be514f43dfd36545bf9c8ab8d580ffee WHIRLPOOL ff351dad7bede38d1b1749cfb74b18c853c11e9e3db89d112586ce4cdfa51efebb7ab9c06f32e2ff2b5ed6a1b687a44da238de91c6254e12b82f722ba9dc1ade
DIST gazebo-8.1.0.tar.bz2 52442394 SHA256 d24cda8919c49cd0b15a51975d551eed1c7c0bfba7b9aa2b1ca9711bf9441e5e SHA512 d451d068a44c487e7b0a6cef17bbffaa39ec4bb08593c4c05d8c758dd56c1bcdb52e6284254c0d27a984761c0eb944012b8a1061bebf47662f6f3c91d3be955c WHIRLPOOL 82f85c1b115e585f352f2fce9b3fac0fc4fa1a35c4c24ffc00b45fe4dc33bd13df655c6f64acd652b1707af3a2756279c572650da5c52eec27d52414c8a45e7d
77 changes: 77 additions & 0 deletions sci-electronics/gazebo/gazebo-8.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

inherit cmake-utils versionator vcs-snapshot flag-o-matic

DESCRIPTION="A 3D multiple robot simulator with dynamics"
HOMEPAGE="http://gazebosim.org/"
SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"

LICENSE="Apache-2.0"
# Subslot = major version = soname of libs
SLOT="0/8"
KEYWORDS="~amd64"
IUSE="cpu_flags_x86_sse2 libav test"

RDEPEND="
>=dev-libs/protobuf-2:=
virtual/opengl
media-libs/openal
net-misc/curl
dev-libs/tinyxml
dev-libs/tinyxml2
dev-libs/libtar
dev-cpp/tbb
>=dev-games/ogre-1.7.4[freeimage]
>=media-libs/freeimage-3.15.4[png]
sci-libs/libccd
libav? ( >=media-video/libav-9:0= )
!libav? ( >=media-video/ffmpeg-2.6:0= )
sci-libs/gts
>=sci-physics/bullet-2.82
>=dev-libs/sdformat-5.0:=
dev-qt/qtwidgets:5
dev-qt/qtcore:5
dev-qt/qtopengl:5
dev-libs/boost:=[threads]
sci-libs/gdal
virtual/libusb:1
dev-libs/libspnav
media-libs/freeimage
sci-libs/hdf5:=[cxx]
sys-apps/util-linux
media-gfx/graphviz
net-libs/ignition-msgs:=
>=sci-libs/ignition-math-2.3:3=
net-libs/ignition-transport:3=
x11-libs/qwt:6=[qt5]
"
DEPEND="${RDEPEND}
dev-qt/qttest:5
app-text/ronn
app-arch/gzip
virtual/pkgconfig
x11-apps/mesa-progs
test? ( dev-libs/libxslt )
"
CMAKE_BUILD_TYPE=RelWithDebInfo
PATCHES=( "${FILESDIR}/qwt.patch" )

src_configure() {
# doesnt build without it
append-cxxflags "-std=c++11"
# doesnt build with as-needed either
append-ldflags "-Wl,--no-as-needed"

local mycmakeargs=(
"-DUSE_UPSTREAM_CFLAGS=OFF"
"-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
"-DUSE_HOST_CFLAGS=FALSE"
"-DBUILD_TESTING=$(usex test TRUE FALSE)"
"-DENABLE_SCREEN_TESTS=FALSE"
"-DUSE_EXTERNAL_TINYXML2=TRUE"
)
cmake-utils_src_configure
}

0 comments on commit 312e3cf

Please sign in to comment.