Skip to content

Commit

Permalink
x11-misc/gtkdialog: Depend on x11-libs/vte:0= (bug #595912).
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.1
  • Loading branch information
Jeroen Roovers committed Oct 2, 2016
1 parent 5163c7f commit 312f6b7
Showing 1 changed file with 51 additions and 0 deletions.
51 changes: 51 additions & 0 deletions x11-misc/gtkdialog/gtkdialog-0.8.3-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit autotools

DESCRIPTION="A small utility for fast and easy GUI building"
HOMEPAGE="https://code.google.com/p/gtkdialog/"
SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="glade vte"

RDEPEND="
x11-libs/gtk+:2
glade? ( gnome-base/libglade )
vte? ( x11-libs/vte:0= )
"
DEPEND="
${RDEPEND}
virtual/pkgconfig
sys-devel/flex
virtual/yacc
"

DOCS=(
AUTHORS
ChangeLog
TODO
)
PATCHES=(
"${FILESDIR}"/${PN}-0.8.3-optdeps.patch
)

src_prepare() {
mv configure.{in,ac} || die
default
eautoreconf
}

src_configure() {
econf $(use_with glade) $(use_with vte)
}

src_install() {
# Stop make install from running gtk-update-icon-cache
emake DESTDIR="${D}" UPDATE_ICON_CACHE=true install
}

0 comments on commit 312f6b7

Please sign in to comment.