forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-cdr/dolphin-plugins-mountiso: 24.08.0 version bump
Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
2 changed files
with
59 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST dolphin-plugins-23.04.3.tar.xz 272912 BLAKE2B f0eb8bbab16d66f1e964131b436af7d3ae8febc26cf4fe394489a978c701ef2f5689bea7daf9eed8d7ef2f1f2bdba000a487cf7f0704ad30bd25e2d403ce5fae SHA512 8f487ba0bcbe561915064247ddb2327c3b7c8fa6ffc5c511d9c9ef37bd4f28a624533ce7a2da2a86b10b65f37915ca10840517872b40c2fd014cead6da5972c8 | ||
DIST dolphin-plugins-23.08.5.tar.xz 274124 BLAKE2B c8b43bd7f87c7221023e75e3f66b450844b379d5bfc95e37ce01dfe983ba3dc234a319da2aaf0596e6eb54319bc4310c718b57d52d070f0f86cd67c6f67a8c4b SHA512 2dd30070660df63b988cda2e14f3ddc27a0cf451119d2a6b121cb9cbeb8788b94498ef25ca434501843784a8e24c4539fe17cc0ab5a158befbc9db5792944852 | ||
DIST dolphin-plugins-24.05.2.tar.xz 305512 BLAKE2B 4f5a2b8e7e7131d55610622669398c537f5ef2a0f69bdcce431d28efd1784e31bd57fccabe93d380d38b7cfbbedb0f7ef79deb6de297deba57420373767c9a38 SHA512 7e8df3f14f0db6114a85e3077a515ea598f436d52ce6d199ead97119604455e06cc8585281cd2aa49068134505bce8bcce461976fad791d5729d278344a30c56 | ||
DIST dolphin-plugins-24.08.0.tar.xz 316660 BLAKE2B 00140dcea345f15caa0bbb50845ad4719cf92420c505ad510c505e9e7a4d0ea8aeb4cd23133bca0f44de34bbf98704545eb9c28f34d5fc8988f2b2154e3db8c2 SHA512 8d72253ecf3b44b4a81ff4ab952913683b2b679220620f153dae4b045e008faccc768e40e48d6dbf41a49a15409e4fa728feee30decbf2a4a35741bf9db87fa3 |
58 changes: 58 additions & 0 deletions
58
app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.08.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,58 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
KDE_ORG_CATEGORY="sdk" | ||
KDE_ORG_NAME="dolphin-plugins" | ||
MY_PLUGIN_NAME="mountiso" | ||
KFMIN=6.5.0 | ||
PVCUT=$(ver_cut 1-3) | ||
QTMIN=6.7.2 | ||
inherit ecm gear.kde.org | ||
|
||
DESCRIPTION="Dolphin plugin for ISO loopback device mounting" | ||
HOMEPAGE="https://apps.kde.org/dolphin_plugins/" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="6" | ||
KEYWORDS="~amd64 ~arm64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
>=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets] | ||
>=kde-apps/dolphin-${PVCUT}:6 | ||
>=kde-frameworks/kcompletion-${KFMIN}:6 | ||
>=kde-frameworks/kconfig-${KFMIN}:6 | ||
>=kde-frameworks/kcoreaddons-${KFMIN}:6 | ||
>=kde-frameworks/ki18n-${KFMIN}:6 | ||
>=kde-frameworks/kio-${KFMIN}:6 | ||
>=kde-frameworks/ktextwidgets-${KFMIN}:6 | ||
>=kde-frameworks/solid-${KFMIN}:6 | ||
" | ||
RDEPEND="${DEPEND} | ||
>=kde-apps/dolphin-plugins-common-${PV} | ||
" | ||
|
||
src_prepare() { | ||
ecm_src_prepare | ||
ecm_punt_po_install | ||
# qtconcurrent only required by git | ||
ecm_punt_qt_module Concurrent | ||
# kxmlgui, qtnetwork only required by dropbox | ||
ecm_punt_qt_module Network | ||
ecm_punt_kf_module XmlGui | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBUILD_${MY_PLUGIN_NAME}=ON | ||
-DBUILD_bazaar=OFF | ||
-DBUILD_dropbox=OFF | ||
-DBUILD_git=OFF | ||
-DBUILD_hg=OFF | ||
-DBUILD_makefileactions=OFF | ||
-DBUILD_svn=OFF | ||
) | ||
ecm_src_configure | ||
} |