Skip to content

Commit

Permalink
dev-libs/libbson: bump to 1.6.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
hydrapolic authored and mgorny committed May 19, 2017
1 parent 43d3150 commit 31a17bf
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libbson/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST libbson-1.1.10.tar.gz 4431658 SHA256 211a62a7a6f93ba21b85afc1522c3a367a264b
DIST libbson-1.1.2.tar.gz 4492014 SHA256 acd8026d4e5bf5034b699af136236a8a38c06613d1800fdf54721fe66280b6ae SHA512 03e2ee337445286c14b846cd7545707959b1d351fa466c6292379a85e48ea1a171dae37dd7aff092212239ad59aac6f1ab216ee5de74ef00a8a2a124559e34da WHIRLPOOL 10a4fee34bcc12a730899553d62405784673ee5beecf63a624fb1527c9dddd0403d855a7557f6a35167bffee2b2ebb9f7d3b7ddc64d2e12cc39d95afe89e0db6
DIST libbson-1.3.5.tar.gz 4547720 SHA256 d380cfc30bbb598e64bc5e4b0851f9e8343071292a9e0a101f49ec06211a1b23 SHA512 b55ae1d424f786aabed6567a77cd09aa26c74ab0a09392e88faef8c156b1650c026f86f245bc8431a0ebcf404c4f80eb1b22e978a24289d32692c84375a66596 WHIRLPOOL fb0d2f05e0a8c60da2d3277ec1413799b8e45c23e408fdd136b3ebe4f6e74ed7d58d767792f1d6454bb6e61785f7ae624ff655b94f39ef6007e1f248caf7cad5
DIST libbson-1.3.6.tar.gz 4546329 SHA256 77b4f41154457d56e5b837a1a770800e96f3c30a67f6e5a439bf336a2124fbb4 SHA512 a7da914ed0f03212d4fb01879543f0b2c7629923e33200fe30335a9a90a1082ffa2566c7a556b90a6c7ffbef5665a45ec67f87ffff2a5fcb89830769b1df5130 WHIRLPOOL b86efef2e3841b66ef425c022c1e60a32d6fd02d3cbc0af22c28ac5f6e6eeabb709aa06a353f2e0ed8af0ebf65da6d660edb09523ec196ac0a5f7006be4d998b
DIST libbson-1.6.2.tar.gz 4835257 SHA256 aad410123e4bd8a9804c3c3d79e03344e2df104872594dc2cf19605d492944ba SHA512 f95f5bb829cff3aac6c1d95a159e38396d8fccef66d3026dac8085ba13ec376274cddeb92277d711ac4d40cafd8b89b73e9a9d1cf29e22f7f79aa9422c69488b WHIRLPOOL c82ad25eda07e0acbd793ee16814e1748076b88f552aeed26300a100bf79131d3a79038ce769cffb4722478edc83f55a854c6d08026c09e87f2ee855c559829f
53 changes: 53 additions & 0 deletions dev-libs/libbson/libbson-1.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools

DESCRIPTION="A BSON utility library"
HOMEPAGE="https://github.com/mongodb/libbson"
SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="debug examples static-libs"

DOCS=( AUTHORS NEWS README )

src_prepare() {
default_src_prepare
# https://github.com/mongodb/mongo-c-driver/issues/54
sed -i -e "s/PTHREAD_LIBS/PTHREAD_CFLAGS/g" src/bson/Makefile.am \
tests/Makefile.am || die
eautoreconf
}

src_configure() {
econf --disable-optimizations \
$(use_enable debug) \
$(use_enable static-libs static)
}

src_install() {
default

# Installing all the manuals conflicts with man-pages
doman doc/man/bson_*.3

if ! use static-libs; then
find "${D}" -name '*.la' -delete || die
fi

if use examples; then
docinto examples
dodoc examples/*.c
fi

einstalldocs
}

src_test() {
emake test
}

0 comments on commit 31a17bf

Please sign in to comment.