Skip to content

Commit

Permalink
dev-lua/lua_cliargs: initial commit
Browse files Browse the repository at this point in the history
  • Loading branch information
williamh committed Nov 11, 2015
1 parent fcca8f4 commit 31a2357
Show file tree
Hide file tree
Showing 3 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lua/lua_cliargs/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST lua_cliargs-2.5_p5.tar.gz 19513 SHA256 7b410dc3665b9bde5d954bfa73fb8254bfd5b4e72b20924f59006ce2f080baf4 SHA512 7c4d490f5d86b07bdf299c976b99bf83c9ba86fabeb321f348587f8ad207983292e3e9268ef72f3cc6ff9d6e32a43669de1d3c21c47499852f971c2cc2a4e746 WHIRLPOOL 07991c547513cc42d5596424651b4a119c30c5ff2dd7a1cabcd125a3198ceebf9f9d466f5110a684af2497cb48afff009aed922719c3115a34823481d194c53b
37 changes: 37 additions & 0 deletions dev-lua/lua_cliargs/lua_cliargs-2.5_p5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit toolchain-funcs

# Below is the upstream package version.
# The final component of the version number has been mapped to the _px
# component of the version number in portage so should be kept in sync.
MY_PV="2.5-5"

DESCRIPTION="A command-line argument parser."
HOMEPAGE="https://github.com/amireh/lua_cliargs"
SRC_URI="https://github.com/amireh/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

COMMON_DEPEND=">=dev-lang/lua-5.1:="
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig"
RDEPEND="${COMMON_DEPEND}"

S="${WORKDIR}/${PN}-${MY_PV}"

src_install() {
insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
doins src/cliargs.lua
dodoc README.md
dodoc -r examples
docinto html
dodoc -r doc/*
}
14 changes: 14 additions & 0 deletions dev-lua/lua_cliargs/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
<email>[email protected]</email>
<name>William Hubbs</name>
</maintainer>
<longdescription lang="en">
This module adds support for accepting CLI
arguments easily using multiple notations and argument types.

cliargs allows you to define required, optional, and flag arguments.
</longdescription>
</pkgmetadata>

0 comments on commit 31a2357

Please sign in to comment.