Skip to content

Commit

Permalink
Merge remote-tracking branch 'remotes/sbraz/plyvel'
Browse files Browse the repository at this point in the history
Pull request: gentoo#641
  • Loading branch information
Ian Delaney committed Jan 13, 2016
2 parents 4330b52 + 08ffd63 commit 31b95fc
Show file tree
Hide file tree
Showing 50 changed files with 623 additions and 1,728 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -10,9 +10,7 @@ inherit distutils-r1 eutils versionator

DESCRIPTION="Model-driven deployment, config management, and command execution framework"
HOMEPAGE="http://ansible.com/"
# the version here is special because upstream did a 2.0.0 release on accident one time...
MY_PV=$(replace_version_separator 1 '.0.')
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
Expand Down
8 changes: 4 additions & 4 deletions app-admin/ansible/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -18,10 +18,10 @@
<remote-id type="github">ansible/ansible</remote-id>
<bugs-to>https://github.com/ansible/ansible/issues</bugs-to>
</upstream>
<use>
<flag name="keyczar">Enable accelerated mode for old ssh clients/servers</flag>
<flag name="paramiko">Enable the use of the paramiko transport, an alternitive to ssh</flag>
</use>
<use>
<flag name="keyczar">Enable accelerated mode for old ssh clients/servers</flag>
<flag name="paramiko">Enable the use of the paramiko transport, an alternitive to ssh</flag>
</use>
<longdescription lang="en">
Radically simple deployment, model-driven configuration management, and
command execution framework.
Expand Down
1 change: 1 addition & 0 deletions app-admin/lastpass-cli/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST lastpass-cli-0.6.0.tar.gz 65047 SHA256 e48f210b34a030e8b8cef3e1d05957aabe757ea4cd31bf03c46b70ddc830733c SHA512 ceaa660e6a7d3b27b09ce6d1d522af216e2c8357859d87034f7f887b53631bf5214b02400f8cb91d0c0020fcfb7889dd0fd8731b1af76a63f94666de2ac4dcd4 WHIRLPOOL 4554d8576e71a0b4c7d69556614a33f3e34d85aec4dd6aa50973ba8eb212864fc45bf3a7cb4e2847cb60a00546e46652cf5baf7f34872ada23431e78078cc6ed
DIST lastpass-cli-0.7.1.tar.gz 68232 SHA256 e9e2d1dbbb6be0b0d9ce8d6c24026fc537cadc824528c96ac562737a90152f5c SHA512 c6be9b4cf30165835dd4e8716992d43246c91c4e9177226285b5a5214fd5927774155cc75b9aad66c69ec8b10ca0b0e00485a429e2bd064dd406fc55f275a295 WHIRLPOOL b88d4de9fdb120463a8454c098c12a1e2a366429904dec82d271b4ef287bdce192efef5de297733c3a38be21f3241ff402c8448a96daa195b986c671456b0b1d
DIST lastpass-cli-0.8.0.tar.gz 79167 SHA256 c5c6076a9a80de275f7fc57275d303cc0c4eb21ff06f705659047abc09a8595b SHA512 2bbaffbe31ed95bda77cec82d5f702f92a311798590d9d41f63f920e50f79b2b7a9ab9b6fb05f4e0650ea4ba75d3e845b817a4f4206f316bc2cdba0de85f9999 WHIRLPOOL 9f7da593457555e50a0450cb0cb4d9d9a8e9b940566158eaf95b21b0865d8f14d19211c9e9fcf9794784695ffc1df66712ed569b3f1cabb472260a0b5c7b1106
34 changes: 34 additions & 0 deletions app-admin/lastpass-cli/lastpass-cli-0.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

DESCRIPTION="Interfaces with LastPass.com from the command line."
SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
HOMEPAGE="https://github.com/lastpass/lastpass-cli"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE="libressl X +pinentry"

RDEPEND="
X? ( || ( x11-misc/xclip x11-misc/xsel ) )
!libressl? ( dev-libs/openssl:0 )
libressl? ( dev-libs/libressl )
net-misc/curl
dev-libs/libxml2
pinentry? ( app-crypt/pinentry )
"
DEPEND="${RDEPEND} app-text/asciidoc"

src_compile() {
emake PREFIX="${EPREFIX}/usr"
emake PREFIX="${EPREFIX}/usr" doc-man
}

src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install-doc
}
26 changes: 14 additions & 12 deletions app-admin/lastpass-cli/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,19 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
<email>[email protected]</email>
<name>Jeff Horelick</name>
</maintainer>
<use>
<flag name="X">
<herd>proxy-maintainers</herd>
<maintainer>
<email>[email protected]</email>
<name>Gokturk 'gokturk' Yuksek</name>
</maintainer>
<use>
<flag name="X">
Use <pkg>x11-misc/xclip</pkg> or <pkg>x11-misc/xsel</pkg> to copy passwords to the clipboard.
</flag>
<flag name="pinentry">
Use <pkg>app-crypt/pinentry</pkg> to prompt for passwords.
<flag name="pinentry">
Use <pkg>app-crypt/pinentry</pkg> to prompt for passwords.
</flag>
</use>
<upstream>
<remote-id type="github">lastpass/lastpass-cli</remote-id>
</upstream>
</use>
<upstream>
<remote-id type="github">lastpass/lastpass-cli</remote-id>
<bugs-to>https://github.com/lastpass/lastpass-cli/issues</bugs-to>
</upstream>
</pkgmetadata>
Original file line number Diff line number Diff line change
Expand Up @@ -73,7 +73,7 @@

IF (NOT(OSG_USE_LOCAL_LUA_SOURCE))
- FIND_PACKAGE(Lua52)
+ MACRO_OPTIONAL_FIND_PACKAGE(Lua52)
+ MACRO_OPTIONAL_FIND_PACKAGE(Lua)
IF (NOT (LUA_LIBRARIES AND LUA_INCLUDE_DIR))
- FIND_PACKAGE(Lua51)
+ MACRO_OPTIONAL_FIND_PACKAGE(Lua51)
Expand Down
4 changes: 2 additions & 2 deletions dev-games/openscenegraph/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -13,10 +13,10 @@ The OpenSceneGraph is an open source high performance 3D graphics toolkit, used
<flag name="asio">Enable support for <pkg>dev-cpp/asio</pkg> library</flag>
<flag name="fox">Build examples using <pkg>x11-libs/fox</pkg> library</flag>
<flag name="gdal">Enable support for <pkg>sci-libs/gdal</pkg> library</flag>
<flag name="las">Enable support for geospatial data LAS LiDAR format using <pkg>sci-geosciences/liblas</pkg></flag>
<flag name="openinventor">Build OpenInventor plugin</flag>
<flag name="osgapps">Build osg applications</flag>
<flag name="sdl2">Use <pkg>media-libs/libsdl2</pkg> additionally to
<pkg>media-libs/libsdl</pkg></flag>
<flag name="sdl2">Use <pkg>media-libs/libsdl2</pkg> additionally to <pkg>media-libs/libsdl</pkg></flag>
<flag name="xrandr">Enable support for the X xrandr extension</flag>
</use>
</pkgmetadata>
22 changes: 16 additions & 6 deletions dev-games/openscenegraph/openscenegraph-3.4.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -16,14 +16,15 @@ SRC_URI="http://trac.openscenegraph.org/downloads/developer_releases/${MY_P}.zip

LICENSE="wxWinLL-3 LGPL-2.1"
SLOT="0/34" # Subslot consists of major + minor version number
KEYWORDS="~amd64 ~x86"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="asio curl debug doc examples ffmpeg fltk fox gdal gif glut gstreamer gtk jpeg
jpeg2k openexr openinventor osgapps pdf png qt4 qt5 sdl sdl2 svg tiff truetype vnc
wxwidgets xine xrandr zlib"
jpeg2k las lua openexr openinventor osgapps pdf png qt4 qt5 sdl sdl2 svg tiff truetype
vnc wxwidgets xine xrandr zlib"

REQUIRED_USE="
qt4? ( !qt5 )
qt5? ( !qt4 )
sdl2? ( sdl )
"

# TODO: COLLADA, FBX, GTA, ITK, OpenVRML, Performer, DCMTK
Expand All @@ -39,8 +40,7 @@ RDEPEND="
fox? ( x11-libs/fox:1.6[opengl] )
glut? ( media-libs/freeglut )
gtk? ( x11-libs/gtkglext )
sdl? ( media-libs/libsdl
sdl2? ( media-libs/libsdl2 ) )
sdl2? ( media-libs/libsdl2 )
wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER}[opengl,X] )
)
ffmpeg? ( virtual/ffmpeg )
Expand All @@ -52,6 +52,8 @@ RDEPEND="
)
jpeg? ( virtual/jpeg:0 )
jpeg2k? ( media-libs/jasper )
las? ( >=sci-geosciences/liblas-1.8.0 )
lua? ( >=dev-lang/lua-5.1.5:* )
openexr? (
media-libs/ilmbase
media-libs/openexr
Expand All @@ -70,6 +72,7 @@ RDEPEND="
dev-qt/qtopengl:5
dev-qt/qtwidgets:5
)
sdl? ( media-libs/libsdl )
svg? (
gnome-base/librsvg
x11-libs/cairo
Expand Down Expand Up @@ -109,6 +112,10 @@ src_configure() {
-DDYNAMIC_OPENSCENEGRAPH=ON
-DWITH_ITK=OFF
-DGENTOO_DOCDIR="/usr/share/doc/${PF}"
-DOPENGL_PROFILE=GL2 #GL1 GL2 GL3 GLES1 GLES3 GLES3
-DOSG_USE_LOCAL_LUA_SOURCE=OFF
-DWITH_Lua51=OFF # We use CMake-version FindLua.cmake instead
-DWITH_Lua52=OFF
$(cmake-utils_use_with asio)
$(cmake-utils_use_with curl)
$(cmake-utils_use_build doc DOCUMENTATION)
Expand All @@ -121,15 +128,18 @@ src_configure() {
$(cmake-utils_use_with gif GIFLIB)
$(cmake-utils_use_with glut)
$(cmake-utils_use_with gstreamer GStreamer)
$(cmake-utils_use_with gstreamer GLIB)
$(cmake-utils_use_with gtk GtkGl)
$(cmake-utils_use_with jpeg)
$(cmake-utils_use_with jpeg2k Jasper)
$(cmake-utils_use_with las LIBLAS)
$(cmake-utils_use_with lua)
$(cmake-utils_use_with openexr OpenEXR)
$(cmake-utils_use_with openinventor Inventor)
$(cmake-utils_use_with pdf Poppler-glib)
$(cmake-utils_use_with png)
$(cmake-utils_use_with sdl)
$(cmake_utils_use_with sdl2)
$(cmake-utils_use_with sdl2)
$(cmake-utils_use_with svg rsvg)
$(cmake-utils_use_with tiff)
$(cmake-utils_use_with truetype Freetype)
Expand Down
51 changes: 30 additions & 21 deletions dev-python/matplotlib/matplotlib-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 python3_{3,4,5} )

PYTHON_REQ_USE='tk?,threads(+)'

inherit distutils-r1 eutils flag-o-matic git-r3 virtualx toolchain-funcs
inherit distutils-r1 eutils flag-o-matic git-r3 multiprocessing virtualx toolchain-funcs

DESCRIPTION="Pure python plotting library with matlab like syntax"
HOMEPAGE="http://matplotlib.org/"
Expand All @@ -22,18 +22,18 @@ SLOT="0"
# Fonts: BitstreamVera, OFL-1.1
LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
KEYWORDS=""
IUSE="cairo doc excel examples fltk gtk gtk3 latex pyside qt4 qt5 test tk wxwidgets"
IUSE="cairo doc excel examples fltk gtk2 gtk3 latex pyside qt4 qt5 test tk wxwidgets"

PY2_FLAGS="|| ( $(python_gen_useflags python2_7) )"
REQUIRED_USE="
doc? ( ${PY2_FLAGS} )
excel? ( ${PY2_FLAGS} )
fltk? ( ${PY2_FLAGS} )
gtk? ( ${PY2_FLAGS} )
gtk2? ( ${PY2_FLAGS} )
wxwidgets? ( ${PY2_FLAGS} )
test? (
cairo fltk latex pyside qt5 qt4 tk wxwidgets
|| ( gtk gtk3 )
|| ( gtk2 gtk3 )
)"

# #456704 -- a lot of py2-only deps
Expand All @@ -48,7 +48,13 @@ COMMON_DEPEND="
media-libs/freetype:2
media-libs/libpng:0
media-libs/qhull
gtk? (
cairo? (
|| (
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/cairocffi[${PYTHON_USEDEP}]
)
)
gtk2? (
dev-libs/glib:2=
x11-libs/gdk-pixbuf
x11-libs/gtk+:2
Expand All @@ -59,14 +65,17 @@ COMMON_DEPEND="
# dev-python/pycxx

DEPEND="${COMMON_DEPEND}
dev-python/versioneer[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
virtual/pkgconfig
doc? (
app-text/dvipng
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/mock[${PY2_USEDEP}]
dev-python/numpydoc[${PYTHON_USEDEP}]
dev-python/xlwt[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/xlwt[${PYTHON_USEDEP}]
dev-texlive/texlive-latexextra
dev-texlive/texlive-fontsrecommended
dev-texlive/texlive-latexrecommended
Expand All @@ -79,12 +88,6 @@ DEPEND="${COMMON_DEPEND}

RDEPEND="${COMMON_DEPEND}
>=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
cairo? (
|| (
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/cairocffi[${PYTHON_USEDEP}]
)
)
excel? ( dev-python/xlwt[${PYTHON_USEDEP}] )
fltk? ( dev-python/pyfltk[${PYTHON_USEDEP}] )
gtk3? (
Expand Down Expand Up @@ -133,15 +136,20 @@ python_prepare_all() {
# rm -r agg24 CXX || die
# rm -r agg24 || die

# cat > lib/${PN}/externals/six.py <<-EOF
# from __future__ import absolute_import
# from six import *
# EOF

sed \
-e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
-i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
|| die "sed pyparsing failed"

# suggested by upstream
sed \
-e '/tol/s:32:35:g' \
-i lib/matplotlib/tests/test_mathtext.py || die
# sed \
# -e '/tol/s:32:35:g' \
# -i lib/matplotlib/tests/test_mathtext.py || die

sed \
-e "s:/usr/:${EPREFIX}/usr/:g" \
Expand Down Expand Up @@ -201,7 +209,7 @@ python_configure() {
cat >> "${BUILD_DIR}"/setup.cfg <<-EOF
six = False
$(use_setup fltk)
$(use_setup gtk)
$(use_setup gtk2 gtk)
$(use_setup gtk3)
$(use_setup wxwidgets wx)
EOF
Expand Down Expand Up @@ -236,10 +244,11 @@ python_compile_all() {
python_test() {
wrap_setup distutils_install_for_testing

cd "${TMPDIR}" || die
VIRTUALX_COMMAND="${PYTHON}"
virtualmake -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)" || \
die "Tests fail with ${EPYTHON}"
virtx ${PYTHON} tests.py \
--no-pep8 \
--no-network \
--verbose \
--processes=$(makeopts_jobs)
}

python_install() {
Expand Down
1 change: 1 addition & 0 deletions dev-python/plyvel/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST plyvel-0.9.tar.gz 121513 SHA256 587d93681ae44936ae086b4b45486eb302e3853ba5af149aac3be9e9713998e9 SHA512 21a3bf0bff075e429fef63418c2a2578b22a4904cc2f4f66fc5fbccec22c762d918bea0622a22dcbeee2e60f8d35210ae8f1e63b6d37405f0fdf29ca2fe80586 WHIRLPOOL baf98bb318bb402ba26d98b1a4657a72b7b1b93dda7e0f0b667b66af798cd6e7723a1ae740265a88266ab608023de8b3d350873560117bf9557f2e8abf792453
14 changes: 14 additions & 0 deletions dev-python/plyvel/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>proxy-maintainers</herd>
<maintainer>
<email>[email protected]</email>
<name>Louis Sautier</name>
<description>Proxied maintainer; set to assignee in all bugs</description>
</maintainer>
<upstream>
<remote-id type="pypi">plyvel</remote-id>
<remote-id type="bitbucket">wbolster/plyvel</remote-id>
</upstream>
</pkgmetadata>
Loading

0 comments on commit 31b95fc

Please sign in to comment.