Skip to content

Commit

Permalink
app-crypt/kbfs: Version bump to 1.0.44
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
nicolasbock committed Feb 26, 2018
1 parent 2f77e18 commit 31c9103
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-crypt/kbfs/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST kbfs-1.0.36.tar.gz 5135197 BLAKE2B a0d40048d11347a72ac9fedb358be7bd8d425e9eafc32fce44e75583aa75fde00bee62d81e7d4bc1553aec3f72ca3af1dffd1ef710d897ce28cb26d152eab4aa SHA512 eb50c4fdd07e0d0e0bd62c48a60520fe48a6b64d97e6ac561d0c567e50c4863f9969697f78553360e6b42776af4974b086bd0be75db6de4c28a5c4a840725919
DIST kbfs-1.0.40.tar.gz 5432507 BLAKE2B 4d3c55d3c081cb7fea44d302a1a5598df515f98f4f75bf3e0eee84c3151114247eb1a80ea2ff9bb6d10cc3612af25e283b114b26b24043fbfdd16f05d2fb0210 SHA512 c5391e710fc55130437ff5f42e00229ea06fd1bd5e535c814158a501f2b23ef43d65d27ebf57ec3c3b5d3c7cbbed43cd2baf8888af001a3b23a40cbc94d22883
DIST kbfs-1.0.44.tar.gz 5440024 BLAKE2B b8ab744b1bb9fa2e33bd382df92f1e50ed294446106d5723306465cbbadc0e960ad0da834671fa7f01e7ea8ff3486477972f44e927feefd1123d8a8ad4e376f5 SHA512 03e92303f140dbff059f8c954142d6180f388c1e50c2f8af02a30a740d440d5f79be47ad851d021a2b90525bf7b775e471780438b94d1d6403eddbdc0bd41e8e
47 changes: 47 additions & 0 deletions app-crypt/kbfs/kbfs-1.0.44.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DESCRIPTION="Keybase Filesystem (KBFS)"
HOMEPAGE="https://keybase.io/docs/kbfs"
SRC_URI="https://github.com/keybase/kbfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="git"

DEPEND=">=dev-lang/go-1.6:0"
RDEPEND="
app-crypt/gnupg
sys-fs/fuse
"

S="${WORKDIR}/src/github.com/keybase/kbfs"

src_unpack() {
unpack "${P}.tar.gz"
mkdir -p "$(dirname "${S}")" || die
mv "kbfs-${PV}" "${S}" || die
}

src_compile() {
GOPATH="${WORKDIR}" \
go build -v -x \
-tags production \
-o "${T}/kbfsfuse" \
github.com/keybase/kbfs/kbfsfuse
use git && \
GOPATH="${WORKDIR}" \
go build -v -x \
-tags production \
-o "${T}/git-remote-keybase" \
github.com/keybase/kbfs/kbfsgit/git-remote-keybase
}

src_install() {
dobin "${T}/kbfsfuse"
use git && \
dobin "${T}/git-remote-keybase"
}

0 comments on commit 31c9103

Please sign in to comment.