Skip to content

Commit

Permalink
media-sound/picard: sync live ebuild with 2.6.3
Browse files Browse the repository at this point in the history
Signed-off-by: Louis Sautier <[email protected]>
  • Loading branch information
sbraz committed Aug 28, 2021
1 parent 6f54911 commit 31e1233
Showing 1 changed file with 7 additions and 17 deletions.
24 changes: 7 additions & 17 deletions media-sound/picard/picard-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
EAPI=8

PYTHON_COMPAT=( python3_{8,9} )
PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_SINGLE_IMPL=1
DISABLE_AUTOFORMATTING=true

inherit distutils-r1 xdg

if [[ ${PV} = *9999* ]]; then
Expand All @@ -29,16 +29,16 @@ BDEPEND="
"
RDEPEND="
$(python_gen_cond_dep '
dev-python/fasteners[${PYTHON_USEDEP}]
dev-python/PyQt5[declarative,gui,network,widgets,${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
media-libs/mutagen[${PYTHON_USEDEP}]
discid? ( dev-python/python-discid[${PYTHON_USEDEP}] )
')
dev-qt/qtgui:5
media-libs/mutagen
discid? ( dev-python/python-discid )
fingerprints? ( media-libs/chromaprint[tools] )
"

RESTRICT="test" # doesn't work with ebuilds
distutils_enable_tests pytest

python_compile() {
local build_args=(
Expand All @@ -60,13 +60,3 @@ python_install() {
fi
distutils-r1_python_install ${install_args[@]}
}

python_install_all() {
distutils-r1_python_install_all

if [[ -n "${REPLACING_VERSIONS}" ]]; then
elog "If you are upgrading Picard and it does not start, try removing"
elog "Picard's settings:"
elog " rm ~/.config/MusicBrainz/Picard.conf"
fi
}

0 comments on commit 31e1233

Please sign in to comment.