Skip to content

Commit

Permalink
dev-ruby/msgpack: add 0.7.4
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
graaff committed Jan 10, 2016
1 parent b189cc3 commit 31f4b05
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/msgpack/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST msgpack-0.7.1.gem 73216 SHA256 27d6182a94057f1d73f04acbd242c647e089a4bac469d5dc7dc4195afab53947 SHA512 dde9492b6bfa56e070043e4f55beaba1f9fc509df643acb946048b30d566a3e3d9c278f6691bc065507382cfe9a975fd658e2ccfc7370123d67cededf18cd807 WHIRLPOOL 9679761d5b780852ebf6a1cbc3746b63079139c6df86d8c8b9292e6d7fb4268076cc924f7ad51e9b32e8fd54ee200444a28874e537cf94e3e43446fc8e7f7855
DIST msgpack-0.7.4.gem 74752 SHA256 c4fa8f8d727877b3dc9f90dfe0fff0b012df5d49e6498c5a33a4ec03f9e2be72 SHA512 4e78df4abe0f9c91a67f66108ee4e8420651d8d23a6ec7de9241138fd1065ce723ad68648c0bd4572801f800363e7f1f34362312d8f861857ffcdfc7accd950a WHIRLPOOL e08f686772af7e549e3997dfa382c8f94b97fe40ce1de3cb6fbfda01286d1e55bc80854c82869e0a0d54125a855e3761ede25225e9c8b69f5e732581bf23593e
41 changes: 41 additions & 0 deletions dev-ruby/msgpack/msgpack-0.7.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

USE_RUBY="ruby20 ruby21 ruby22"

RUBY_FAKEGEM_TASK_DOC="doc"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_EXTRADOC="README.rdoc"

inherit multilib ruby-fakegem

DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
HOMEPAGE="http://msgpack.org/"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="doc"

ruby_add_bdepend "doc? ( dev-ruby/yard )"

all_ruby_prepare() {
sed -i -e '/bundler/I s:^:#:' Rakefile || die

# Remove jruby-specific specs that are run also for other rubies.
rm -rf spec/jruby || die

sed -i -e '/git ls-files/d' msgpack.gemspec || die
}

each_ruby_configure() {
${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
}

each_ruby_compile() {
emake V=1 -Cext/${PN}
cp ext/${PN}/msgpack$(get_modname) lib/${PN} || die "Unable to install msgpack library."
}

0 comments on commit 31f4b05

Please sign in to comment.