Skip to content

Commit

Permalink
media-video/mkvtoolnix: bump to 9.3.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
aballier committed Jul 18, 2016
1 parent 9e0f987 commit 3214831
Show file tree
Hide file tree
Showing 2 changed files with 116 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-video/mkvtoolnix/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mkvtoolnix-8.5.2.tar.xz 3304356 SHA256 efaae6d5e3d0963e2f53ae9c45f151be28561a6c6a28fad46e6220baf9862bbc SHA512 14a2d3d20499ccc2cfd0b1cfbbaa66def6ba512df0624f3e79d317670c4c17bf6552b9e62daed225b369fbab2fad3ce98877ccb7583096cd61da4c91ffed54ef WHIRLPOOL 536bbf36ac76e46d0205f5b2db58d986065ba38acd513129e0604154130cdf8861f3d8a52cb341980161b302f2853199c031b9908665ff13d2bb7db193a56a66
DIST mkvtoolnix-9.2.0.tar.xz 3706756 SHA256 2c2a6b905acfede9eebfe58652b06c88501169d3b9a3c70af78774733ded8b01 SHA512 f1ccf7520c76576b60f1b88a1b85b93dbaa828946f8510db2a963b63037bdf3f4d810592e928c7e6ed6c1bb48b7872516cbad7db36534e30609d8327cd39ea59 WHIRLPOOL 7f5c29279db55f014e73465c37070770fa0d5593c357ecaf99e4519a68b24990f1badba30afbfe31c4b6f0945eae6ca82c7de2906e320a3b267cc1a156e63a16
DIST mkvtoolnix-9.3.1.tar.xz 3739204 SHA256 f3695761bf0a5fdcd6144cfb0a624094c10c9d66d43a340ebb917b7c6a8b39a2 SHA512 5d7cf6c9816655567b5089201246cf8efeb19a8771e76240eb9e99850ee0a00062d67fbd5cddb25cf1ac5ad02f5efc0a0213f3bffdd8bf1c2f9949a7118029bf WHIRLPOOL b2dde1d60211cfe4d4ebe8652cc5baf3f06a577c9131e1c93b51e89c36a443a508de14347acd9f540f20874c8d290a229f98677d5f15ce95e5dec00fad285c06
115 changes: 115 additions & 0 deletions media-video/mkvtoolnix/mkvtoolnix-9.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,115 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils multilib toolchain-funcs versionator multiprocessing autotools

DESCRIPTION="Tools to create, alter, and inspect Matroska files"
HOMEPAGE="http://www.bunkus.org/videotools/mkvtoolnix"
SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="curl debug pch test qt5"

ruby_atom() {
local ruby_slot=${1/ruby/}
ruby_slot="${ruby_slot:0:1}.${ruby_slot:1:2}"
echo "dev-lang/ruby:${ruby_slot}"
}

# hacks to avoid using the ruby eclasses since this requires something similar
# to the python-any-r1 eclass for ruby which currently doesn't exist
RUBY_IMPLS=( ruby23 ruby22 ruby21 ruby20 )
RUBY_BDEPS="$(for ruby_impl in "${RUBY_IMPLS[@]}"; do
echo "( $(ruby_atom ${ruby_impl}) virtual/rubygems[ruby_targets_${ruby_impl}] )"; done)"

RDEPEND="
>=dev-libs/boost-1.46.0:=
>=dev-libs/libebml-1.3.3:=
dev-libs/pugixml
media-libs/flac
>=media-libs/libmatroska-1.4.4:=
media-libs/libogg
media-libs/libvorbis
sys-apps/file
sys-libs/zlib
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
)
"
DEPEND="${RDEPEND}
|| ( ${RUBY_BDEPS} )
sys-devel/gettext
virtual/pkgconfig
test? ( dev-cpp/gtest )
"

pkg_pretend() {
# https://bugs.gentoo.org/419257
local ver=4.6
local msg="You need at least GCC ${ver}.x for C++11 range-based 'for' and nullptr support."
if ! version_is_at_least ${ver} $(gcc-version); then
eerror ${msg}
die ${msg}
fi
}

src_prepare() {
local ruby_impl
for ruby_impl in "${RUBY_IMPLS[@]}"; do
if has_version "$(ruby_atom ${ruby_impl})"; then
export RUBY=${ruby_impl}
break
fi
done
[[ -z ${RUBY} ]] && die "No available ruby implementations to build with"

epatch_user
eautoreconf
}

src_configure() {
local myconf

if use qt5 ; then
# ac/qt5.m4 finds default Qt version set by qtchooser, bug #532600
myconf+=(
--with-moc=/usr/$(get_libdir)/qt5/bin/moc
--with-uic=/usr/$(get_libdir)/qt5/bin/uic
--with-rcc=/usr/$(get_libdir)/qt5/bin/rcc
)
fi

econf \
$(use_enable debug) \
$(use_enable qt5 qt) \
$(use_with curl) \
$(usex pch "" --disable-precompiled-headers) \
"${myconf[@]}" \
--disable-optimization \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
--with-boost="${EPREFIX}"/usr \
--with-boost-libdir="${EPREFIX}"/usr/$(get_libdir)
}

src_compile() {
"${RUBY}" ./drake V=1 -j$(makeopts_jobs) || die
}

src_test() {
"${RUBY}" ./drake V=1 -j$(makeopts_jobs) tests:unit || die
"${RUBY}" ./drake V=1 -j$(makeopts_jobs) tests:run_unit || die
}

src_install() {
DESTDIR="${D}" "${RUBY}" ./drake -j$(makeopts_jobs) install || die

dodoc AUTHORS ChangeLog README.md
doman doc/man/*.1
}

0 comments on commit 3214831

Please sign in to comment.