Skip to content

Commit

Permalink
games-server/mtavc: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Aug 5, 2016
1 parent 0283d05 commit 323e5b6
Showing 1 changed file with 47 additions and 0 deletions.
47 changes: 47 additions & 0 deletions games-server/mtavc/mtavc-0.5-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils

DESCRIPTION="dedicated server for GTA3 multiplayer"
HOMEPAGE="http://mtavc.com/"
SRC_URI="http://files.gonnaplay.com/201/MTAServer0_5-linux.tar.gz"

LICENSE="MTA-0.5"
SLOT="0"
KEYWORDS="-* ~x86"
IUSE=""

RDEPEND="virtual/libstdc++"
DEPEND=""

S=${WORKDIR}

QA_PREBUILT="/opt/${PN}/MTAServer"
QA_EXECSTACK="/opt/${PN}/MTAServer"

src_prepare() {
default

sed -i 's:NoName:Gentoo:' mtaserver.conf || die
}

src_install() {
local dir=/opt/${PN}
local files="banned.lst motd.txt mtaserver.conf"
local f

dobin "${FILESDIR}"/mtavc
sed -i -e "s:GENTOO_DIR:${dir}:" "${D}/usr/bin"/mtavc

exeinto "${dir}"
newexe MTAServer${PV} MTAServer
insinto /etc/${PN}
doins ${files}
dodoc README CHANGELOG
for f in ${files} ; do
dosym /etc/${PN}/${f} "${dir}"/${f}
done
}

0 comments on commit 323e5b6

Please sign in to comment.