Skip to content

Commit

Permalink
media-video/rtmpdump: Move to EAPI6 and git-r3.
Browse files Browse the repository at this point in the history
Specify dev-libs/openssl and dev-libs/libressl SLOT.

Package-Manager: portage-2.2.28
Closes: gentoo#2210

Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
bjacquin authored and monsieurp committed Sep 14, 2016
1 parent 8dcbb34 commit 3252a86
Show file tree
Hide file tree
Showing 2 changed files with 87 additions and 5 deletions.
79 changes: 79 additions & 0 deletions media-video/rtmpdump/rtmpdump-2.4_p20131018-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,79 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="6"

inherit multilib toolchain-funcs multilib-minimal

DESCRIPTION="RTMP client intended to stream audio or video flash content"
HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"

# the library is LGPL-2.1, the command is GPL-2
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~amd64-fbsd ~amd64-linux ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-linux"
IUSE="gnutls polarssl ssl libressl"

DEPEND="ssl? (
gnutls? ( >=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP},nettle(+)] )
polarssl? ( !gnutls? ( >=net-libs/polarssl-1.3.4[${MULTILIB_USEDEP}] ) )
!gnutls? ( !polarssl? ( !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] ) libressl? ( dev-libs/libressl:0 ) ) )
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
)"
RDEPEND="${DEPEND}"

DOCS=( README ChangeLog )
HTML_DOCS=( rtmpdump.1.html rtmpgw.8.html )

pkg_setup() {
if ! use ssl && { use gnutls || use polarssl; }; then
ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
ewarn "Please review the local USE flags for this package."
fi
}

src_prepare() {
default

# fix #571106 by restoring pre-GCC5 inline semantics
append-cflags -std=gnu89
# fix Makefile ( bug #298535 , bug #318353 and bug #324513 )
sed -i 's/\$(MAKEFLAGS)//g' Makefile \
|| die "failed to fix Makefile"
sed -i -e 's:OPT=:&-fPIC :' \
-e 's:OPT:OPTS:' \
-e 's:CFLAGS=.*:& $(OPT):' librtmp/Makefile \
|| die "failed to fix Makefile"
multilib_copy_sources

if use ssl ; then
if use gnutls ; then
crypto="GNUTLS"
elif use polarssl ; then
crypto="POLARSSL"
else
crypto="OPENSSL"
fi
fi
}

multilib_src_compile() {
#fix multilib-script support. Bug #327449
sed -i "/^libdir/s:lib$:$(get_libdir):" librtmp/Makefile || die
if ! multilib_is_native_abi; then
cd librtmp || die
fi
emake CC="$(tc-getCC)" LD="$(tc-getLD)" \
OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix
}

multilib_src_install() {
mkdir -p "${ED}"/usr/$(get_libdir) || die
if ! multilib_is_native_abi; then
cd librtmp || die
fi
emake DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man" \
CRYPTO="${crypto}" install
}
13 changes: 8 additions & 5 deletions media-video/rtmpdump/rtmpdump-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="4"
EAPI="6"

inherit git-2 multilib toolchain-funcs multilib-minimal
inherit git-r3 multilib toolchain-funcs multilib-minimal

DESCRIPTION="RTMP client intended to stream audio or video flash content"
HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
Expand All @@ -24,6 +24,9 @@ DEPEND="ssl? (
)"
RDEPEND="${DEPEND}"

DOCS=( README ChangeLog )
HTML_DOCS=( rtmpdump.1.html rtmpgw.8.html )

pkg_setup() {
if ! use ssl && { use gnutls || use polarssl; }; then
ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
Expand All @@ -32,6 +35,8 @@ pkg_setup() {
}

src_prepare() {
default

# fix #571106 by restoring pre-GCC5 inline semantics
append-cflags -std=gnu89
# fix Makefile ( bug #298535 , bug #318353 and bug #324513 )
Expand Down Expand Up @@ -65,9 +70,7 @@ multilib_src_compile() {

multilib_src_install() {
mkdir -p "${ED}"/usr/$(get_libdir) || die
if multilib_is_native_abi; then
dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html
else
if ! multilib_is_native_abi; then
cd librtmp || die
fi
emake DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man" \
Expand Down

0 comments on commit 3252a86

Please sign in to comment.