forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-backup/snapper: version bump 0.8.3
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Yixun Lan <[email protected]>
- Loading branch information
Showing
2 changed files
with
78 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST snapper-0.5.6.tar.bz2 580047 BLAKE2B 3b945acbf734db1925dad5515323a64a2c08ee8226a593025f9160e0d1b1140734b2b498d036256946159900b50fec8567147dc0a974c281be747e977bcbd05b SHA512 392427d097cbe221bf7ca0ae20bc065dffaa4d0017ed750c41748d71128fc7ce054bb4425d6dbed7308a530df71815f80f56e60d72aab17ef3e0a16f3b3ba47e | ||
DIST snapper-0.8.1.tar.bz2 591061 BLAKE2B 5f9ae50469f43e930de4c4479428c94b24441832bd713847c6792ff583fb79badfa341b53cc63abfedb787367b22b715de9f83f9172dec945f7b3071c06137ba SHA512 9fa20311f346de54c4f5d1cabb42dce5c677eaac03b3fac2a6049f408553911f5a968b1920fd014f3318ebb6911f2e6bce06463e976b468927e250e16fe783a0 | ||
DIST snapper-0.8.2.tar.bz2 591558 BLAKE2B 552c07d1d83e6a8db1e1661b523aeb7164335bb6ebbeb07489325b6d23d8a5def730ac1cf0da06ab65b7a9fc1284d0d05ca0f875bc897504c1bbb45698b40294 SHA512 d968490782a47112f7ba2474555cafe450833cf055734186c79991dd836f9c5d8d669a6c65dd29b05da298e46f65e0ac5c4a1dae3b548a01dbf1b11d7e00c462 | ||
DIST snapper-0.8.3.tar.bz2 592405 BLAKE2B 7694a6c79e4beaf307801ccd97a6cd1c3c6078e68653e9a5eda3ddcd087ef32f8302d380ee550ac5c7259c7e23ddb15bf9f2d01267d5691fe10e0335d490a258 SHA512 409a8464c10905da1407ce3bf68ad1d7df53480da4f8e98e40ef4ee5cb5170bb99c07fabb367510eb2a19744a827dc9a33cf74de05fbb2fc5f22fe3dc4adef6d |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,77 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit systemd | ||
|
||
DESCRIPTION="Command-line program for btrfs and lvm snapshot management" | ||
HOMEPAGE="http://snapper.io/" | ||
SRC_URI="ftp://ftp.suse.com/pub/projects/snapper/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="lvm pam xattr" | ||
|
||
RDEPEND="dev-libs/boost:=[threads] | ||
dev-libs/libxml2 | ||
dev-libs/icu:= | ||
sys-apps/acl | ||
sys-apps/dbus | ||
sys-apps/util-linux | ||
>=sys-fs/btrfs-progs-3.17.1 | ||
sys-libs/zlib | ||
virtual/libintl | ||
lvm? ( sys-fs/lvm2 ) | ||
pam? ( sys-libs/pam ) | ||
xattr? ( sys-apps/attr )" | ||
|
||
DEPEND="${RDEPEND} | ||
sys-devel/gettext | ||
virtual/pkgconfig" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/cron-confd.patch | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \ | ||
-i data/Makefile.* \ | ||
|| die "Failed to fix systemd services and timers installation path" | ||
} | ||
|
||
src_configure() { | ||
# ext4 code does not work anymore | ||
# snapper does not build without btrfs | ||
local myeconfargs=( | ||
--with-conf="/etc/conf.d" | ||
--docdir="/usr/share/doc/${PF}" | ||
--disable-zypp | ||
--enable-rollback | ||
--disable-ext4 | ||
--enable-btrfs | ||
$(use_enable lvm) | ||
$(use_enable pam) | ||
$(use_enable xattr xattrs) | ||
) | ||
|
||
econf "${myeconfargs[@]}" | ||
} | ||
|
||
src_install() { | ||
default | ||
# Existing configuration file required to function | ||
newconfd data/sysconfig.snapper snapper | ||
find "${D}" -name '*.la' -delete || die | ||
} | ||
|
||
pkg_postinst() { | ||
elog "In order to use Snapper, you need to set up" | ||
elog "at least one config first. To do this, run:" | ||
elog "snapper create-config <subvolume>" | ||
elog "For more information, see man (8) snapper or" | ||
elog "http://snapper.io/documentation.html" | ||
} |