Skip to content

Commit

Permalink
dev-scheme/guile-ncurses: bump to 3.1
Browse files Browse the repository at this point in the history
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed Jan 21, 2023
1 parent 6773238 commit 327c95d
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-scheme/guile-ncurses/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST guile-ncurses-3.0.tar.gz 910030 BLAKE2B e7bfa1e7c7ff8fd4e8b653a5bcada99f8f047142322e4abb946cd42b27bd1d2014f904b5a73d5356ad95bec1c394d0b76ad06204a7d117ab4c2e9a3181633fa2 SHA512 6f36ec57b1835dc90f6691243e3b627e067522c78ea620fc109bf270016034842a933c2d9e09c1a3998a740ae17cb1b7ae291d3e4c578c54128eae4c88a450ac
DIST guile-ncurses-3.1.tar.gz 921257 BLAKE2B 26ee97ac62ae7877ecf4cce9d798f7afadc98cbba914da1c802321bf83572e5bfe9775e6e3739bbe849cde9843998aca001b6753bde9d5fbb48c4d70133740f9 SHA512 c43264cfb0cc9fe658f7ddd53bb3dfc6c7636ecaf9b8f3f416d449e6463e38061faf419b43d91775dd9642a904055122e7992c16dea1532de6229fcfa68e292f
74 changes: 74 additions & 0 deletions dev-scheme/guile-ncurses/guile-ncurses-3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools

DESCRIPTION="Guile FFI to ncurses library for text-based console UI"
HOMEPAGE="https://www.gnu.org/software/guile-ncurses/"
SRC_URI="mirror://gnu/guile-ncurses/${P}.tar.gz"

LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="strip"

RDEPEND="
>=dev-scheme/guile-2.0.0:=
sys-libs/ncurses:=
"
DEPEND="${RDEPEND}"
BDEPEND="sys-apps/texinfo"

# guile generates ELF files without use of C or machine code
# It's a portage's false positive. bug #677600
QA_PREBUILT='*[.]go'

PATCHES=(
"${FILESDIR}"/${PN}-3.0-slibtool.patch # bug #843416
)

src_prepare() {
default

# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die

# Remove bad tests
# > In procedure list-ref: Wrong type argument in position 1: #f
local -a bad_tests=(
curs_attr_attr_off_underline
curs_attr_attr_on_blink
curs_attr_attr_on_bold
curs_attr_attr_on_dim
curs_attr_attr_on_invis
curs_attr_attr_on_protect
curs_attr_attr_on_reverse
curs_attr_attr_on_standout
curs_attr_attr_on_underline
curs_attr_attr_set
curs_attr_attr_set_normal
curs_attr_standend
curs_attr_standout
curs_bkgd_bkgd
curs_bkgd_bkgdset
termios_speed
)
local bad_test
for bad_test in "${bad_tests[@]}" ; do
echo "#t" > test/${bad_test}.scm || die
done

eautoreconf # 843560
}

src_test() {
emake check
}

src_install() {
default

find "${ED}" -type f -name '*.la' -delete || die
}

0 comments on commit 327c95d

Please sign in to comment.