Skip to content

Commit

Permalink
media-libs/adplug: Version bump to 2.3.1
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/645296
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
SoapGentoo committed Apr 22, 2018
1 parent 253ff75 commit 327e2b1
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/adplug/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST adplug-2.2.1.tar.bz2 810257 BLAKE2B a51c85a10af6a1cc308a7ccfa657daab1e627800a0617f6cf8b874726a115bdef188dc3d82fb6af9fd2aadc2b28b12f0707ea12cb52f6656d2b8654849bad806 SHA512 e9b434ad58114a6677907e8f7007a325fa908f9228fbe283d72d1e2394fa27850b929309e038c84ae94f64f8db003b871775502ee8b231219caa51f6ba5d787f
DIST adplug-2.3.1.tar.bz2 1478424 BLAKE2B 8c2b65d11d3b12b4a3337bc9c6ada2920b07279ac0199d4bdf1fa2ceec2f51748a1bb9357456b3e7aba7c906253691066b274e7a7c7578c777d1e2e77f5131f0 SHA512 324ce084ecf5b0d180b335ebcacd5ab80806a5c9fbdeed6ef7cbd6c2f2cb476d9d9f38f596b7d6100e3d6cab42294300559200297b4b3f34190c1f516454c8c3
DIST adplug-2.3.tar.bz2 1462858 BLAKE2B e350c65827d1bfbcbc495bd2986e312a7f572d2f29708ef17566c912bad8ddd2a52d49e065f147fec6ee657def0f2ddedfe65ca6d3b7b0d37d371cf4150ada87 SHA512 591192032772fbedfec67924693fce3fc490e5bccb1898eea8d38b6d10f066373ebdc4868751041dd21461b5112b349f0be7ff047d7ccaa896fe4ece88ebab74
41 changes: 41 additions & 0 deletions media-libs/adplug/adplug-2.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit out-of-source

DESCRIPTION="A free, cross-platform, hardware independent AdLib sound player library"
HOMEPAGE="http://adplug.sourceforge.net"

if [[ ${PV} == *9999 ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/adplug/adplug.git"
else
SRC_URI="https://github.com/adplug/${PN}/releases/download/${P}/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
fi

LICENSE="LGPL-2.1"
SLOT="0/${PV}"
IUSE="debug static-libs"

RDEPEND=">=dev-cpp/libbinio-1.4"
DEPEND="${RDEPEND}
virtual/pkgconfig"

src_prepare() {
default
[[ ${PV} == *9999 ]] && eautoreconf
}

my_src_configure() {
econf \
$(use_enable static-libs static) \
$(use_enable debug)
}

my_src_install_all() {
einstalldocs
find "${D}" -name '*.la' -delete || die
}

0 comments on commit 327e2b1

Please sign in to comment.