forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-php/PEAR-HTTP_Request2: bump to v2.5.0
Package-Manager: Portage-3.0.21, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <[email protected]>
- Loading branch information
Showing
2 changed files
with
37 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST HTTP_Request2-2.3.0.tgz 119717 BLAKE2B f12972b2423258016f4f4ef8888b5aa1d56bb47146cc6e21f74edfd2e3cd8ae69a1830b4a203990e1346554f2a6e9538e8d5feae27cceadc8465b018dd34ff37 SHA512 52fc2768f3c5afe6fd4505d427255e467b5b7cac8a4116cbabc3f1c0ffe6f1bd061a9c9b31de2ebbd4a7844ae73085ab0d52adf905dce28eb31197117657d77b | ||
DIST HTTP_Request2-2.4.1.tgz 125380 BLAKE2B 0037938211432be52af8851b015f8c8ef73225fbbc1727e6e647d2e9632fa471a73ae14c4f8c0ea636fb97339dfd53da91bd391543bc855dc9a123ca7a707965 SHA512 9a65aee4c4f724a84815d683522225d36a8e30fc1f5dbbe6b4681ec264b4fb711573bd6d2ec6ddc228c9e259ffbeeb6816aadba155530e969c7bfac4e0617e2b | ||
DIST HTTP_Request2-2.4.2.tgz 125530 BLAKE2B 3e614e45e40b075930781b9e3cc0ed657f10056aa40bce28910ae9499e9db39a6f36410f632254061a002818343b4454639f4b48f23687e0db665b204275ad0c SHA512 c122df64f3f87d562fd4f818b3f02f7639dc907f724d034c420ddeabc5295d0a94d77221287349bcb7a790a97cf7c9b078d9a8086a476789eae906c6e124c910 | ||
DIST HTTP_Request2-2.5.0.tgz 126988 BLAKE2B 5d1f4f2e3e9b800377c14688529ea322084f126c388f675b5d33ae99ba9d3a10e5da0e30d92984f1ba40e92da908917362e459f7b8415e61a85ad797ca38411f SHA512 a333109077758c0899e74e1037484e749825c87f182e2388bb9a0a7e0a881b1f1aec7b9f7a327ff428e32f874df263e7b4b7714be4d8f86cac9370f31aff2d0f |
36 changes: 36 additions & 0 deletions
36
dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.5.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit php-pear-r2 | ||
|
||
DESCRIPTION="Provides an easy way to perform HTTP requests" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86" | ||
IUSE="+curl +fileinfo +ssl test +zlib" | ||
|
||
# We don't have Yoast\PHPUnitPolyfills in Gentoo | ||
# and we would need to patch sources to find it | ||
RESTRICT="test" | ||
|
||
RDEPEND="dev-lang/php:*[curl?,fileinfo?,ssl?,zlib?] | ||
>=dev-php/PEAR-Net_URL2-2.2.0" | ||
DEPEND="test? ( ${RDEPEND} dev-php/phpunit )" | ||
|
||
src_prepare() { | ||
sed -i "s~@data_dir@~${EPREFIX}/usr/share/php/data~" HTTP/Request2/CookieJar.php || die | ||
default | ||
} | ||
|
||
src_test() { | ||
phpunit tests || die | ||
} | ||
|
||
src_install() { | ||
php-pear-r2_src_install | ||
insinto "/usr/share/php/data/${PHP_PEAR_PKG_NAME}" | ||
doins data/* | ||
} |