Skip to content

Commit

Permalink
gnustep-libs/sope: 4.1.1 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <[email protected]>
  • Loading branch information
voyageur committed Dec 10, 2019
1 parent 797e720 commit 32b874e
Show file tree
Hide file tree
Showing 2 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnustep-libs/sope/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST sope-4.0.7.tar.gz 2200743 BLAKE2B 1ab31ca92821b5febbcfa7776292a565216e40d6fdbe9afdf8bb97bb445a654716d3abd4736821b881cb464c3b7e46353910ab38fd853f89581eb248db0155d3 SHA512 6d723278f714f01b215e7b0cf046008b6448c84daddde4ad1f3434b8154a8bcede3adaa11c980b4f4b9c4950a07d545185483cf8ba75a8bac91e86437dc6e74b
DIST sope-4.0.8.tar.gz 2201872 BLAKE2B e0838fcf462bdd143a9b42aba0c775e414769f04f351073238f3554d24c95103f8fc781dcb57c540e295af6d92586e2c3da3e730952155f063dd7e8844959e04 SHA512 6ecf9b473e3b8e556578efc74036e60fb4b07cad837df034471f56dfc08507332470b2ced2db6c5206adbf73cf27c1743b57fa8fc154d9bd7a7865f68c1fa98c
DIST sope-4.1.1.tar.gz 2202428 BLAKE2B 551306a5d722442d60f68d132a21023bd7acf2fb2dcefdfcb0e1a053c03bf3c5af3afc954ec4b76e4db56799ff8cdd931ca8038fb7b3c41e5dff915858e49013 SHA512 fe672ba3b6b42bcc67f98efcb49bbe7f61f3e2fa9a0b2c571b60978425714916fe35f43283f27efaf8d568e53e6e0b6b1f80a7a63cf5b3df001e1d591cb386df
62 changes: 62 additions & 0 deletions gnustep-libs/sope/sope-4.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit gnustep-2 vcs-snapshot

DESCRIPTION="A set of frameworks forming a complete Web application server environment"
HOMEPAGE="http://www.sogo.nu/"
SRC_URI="https://github.com/inverse-inc/sope/archive/SOPE-${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gnutls ldap libressl mysql postgres +ssl +xml"

RDEPEND="
sys-libs/zlib
ldap? ( net-nds/openldap )
gnutls? ( net-libs/gnutls:= )
!gnutls? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
)
mysql? ( dev-db/mysql-connector-c:= )
postgres? ( dev-db/postgresql:= )
xml? ( dev-libs/libxml2:2 )
"
DEPEND="${RDEPEND}"

pkg_pretend() {
if use ssl && use gnutls && use libressl ; then
ewarn "You have enabled both gnutls and libressl, but only"
ewarn "one provider can be active. Using gnutls!"
fi
}

src_configure() {
local ssl_provider
if use ssl ; then
if use gnutls ; then
ssl_provider=gnutls
else
ssl_provider=ssl
fi
else
ssl_provider=none
fi

egnustep_env

# Non-standard configure script
./configure \
--disable-strip \
$(use_enable debug) \
$(use_enable ldap openldap) \
$(use_enable mysql) \
$(use_enable postgres postgresql) \
$(use_enable xml) \
--with-ssl="${ssl_provider}" \
--with-gnustep || die "configure failed"
}

0 comments on commit 32b874e

Please sign in to comment.