Skip to content

Commit

Permalink
media-sound/rhythmbox: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
pacho2 committed Jan 30, 2016
1 parent d9ae127 commit 32f74b8
Show file tree
Hide file tree
Showing 2 changed files with 150 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/rhythmbox/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST rhythmbox-3.2.1.tar.xz 6833060 SHA256 bf43ca4f5b7531751241f5e67eaba7da6d9748dd827a600eedf9444961537938 SHA512 866d6e4a4a3b5561ac76b38ac87001f20b4cfa4e9ad201060a556eac004c72f834a15368d132c1fa59172d0dbdf73e14f8a2f7ea1f10274a4f7fcd50562e9a34 WHIRLPOOL a4c942245e876766dd9b6fd1ba44b463d6f33d7a568e13c3d76da56045c90c2b34cf43749fa5b243b93d50e566a194753dc9ba6202366c35618aa81cafcebdfc
DIST rhythmbox-3.3.tar.xz 6863500 SHA256 5299ac4d3dbc4e281aa422e957b3a7741207512ae051fdfc8159e1322b486859 SHA512 ff717015ec0d95e72abf7f356b3d83bfac744d3d032d35bf9b0f5452caa8e9130bc7446d8079f9e36eaa07b518dea5a6c2fc848cf326c9d0bd1ab17d58a95518 WHIRLPOOL faeedadb1735b9a77c75ecaa80d0c14608d3186916d81e2647c9c3d981305c24d8972f1c93d0b197a3c81140a8559eb4ecf38f506818cf9ebc703b53b9926e89
149 changes: 149 additions & 0 deletions media-sound/rhythmbox/rhythmbox-3.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,149 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python3_{3,4,5} )
PYTHON_REQ_USE="xml"

inherit eutils gnome2 python-r1 multilib virtualx

DESCRIPTION="Music management and playback software for GNOME"
HOMEPAGE="https://wiki.gnome.org/Apps/Rhythmbox"

LICENSE="GPL-2"
SLOT="0"

IUSE="cdr daap dbus gnome-keyring ipod libnotify lirc mtp nsplugin +python
test +udev upnp-av visualizer zeitgeist"
REQUIRED_USE="
ipod? ( udev )
mtp? ( udev )
dbus? ( python )
python? ( ^^ ( $(python_gen_useflags '*') ) )
"
# webkit? ( python )

KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"

# Tests failing for years without upstream caring at all
# upstream bug #688745
RESTRICT="test"

COMMON_DEPEND="
>=dev-libs/glib-2.34:2
>=dev-libs/libxml2-2.7.8:2
>=x11-libs/gtk+-3.12.0:3[X,introspection]
>=x11-libs/gdk-pixbuf-2.18:2
>=dev-libs/gobject-introspection-0.10:=
>=dev-libs/libpeas-0.7.3[gtk,python?]
>=dev-libs/totem-pl-parser-3.2
>=net-libs/libsoup-2.34:2.4
media-libs/gst-plugins-base:1.0[introspection]
media-libs/gstreamer:1.0[introspection]
>=sys-libs/tdb-1.2.6
dev-libs/json-glib
visualizer? (
>=media-libs/clutter-1.8:1.0
>=media-libs/clutter-gst-1.9.92:2.0
>=media-libs/clutter-gtk-1.0:1.0
>=x11-libs/mx-1.0.1:1.0
media-plugins/gst-plugins-libvisual:1.0 )
cdr? ( >=app-cdr/brasero-2.91.90 )
daap? (
>=net-libs/libdmapsharing-2.9.19:3.0
media-plugins/gst-plugins-soup:1.0 )
gnome-keyring? ( >=app-crypt/libsecret-0.18 )
libnotify? ( >=x11-libs/libnotify-0.7.0 )
lirc? ( app-misc/lirc )
python? ( >=dev-python/pygobject-3.0:3[${PYTHON_USEDEP}] )
udev? (
virtual/libgudev:=
ipod? ( >=media-libs/libgpod-0.7.92[udev] )
mtp? ( >=media-libs/libmtp-0.3 ) )
zeitgeist? ( gnome-extra/zeitgeist )
"
# html? ( >=net-libs/webkit-gtk-1.10:3 )
RDEPEND="${COMMON_DEPEND}
media-plugins/gst-plugins-soup:1.0
media-plugins/gst-plugins-libmms:1.0
|| (
media-plugins/gst-plugins-cdparanoia:1.0
media-plugins/gst-plugins-cdio:1.0 )
media-plugins/gst-plugins-meta:1.0
media-plugins/gst-plugins-taglib:1.0
x11-themes/adwaita-icon-theme
upnp-av? (
>=media-libs/grilo-0.2:0.2
>=media-plugins/grilo-plugins-0.2:0.2[upnp-av] )
python? (
>=dev-libs/libpeas-0.7.3[${PYTHON_USEDEP}]
x11-libs/gdk-pixbuf:2[introspection]
x11-libs/gtk+:3[introspection]
x11-libs/pango[introspection]
dbus? ( sys-apps/dbus )
gnome-keyring? ( >=app-crypt/libsecret-0.18[introspection] ) )
"
# webkit? (
# dev-python/mako[${PYTHON_USEDEP}]
# >=net-libs/webkit-gtk-1.10:3[introspection] ) )

DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
app-text/yelp-tools
dev-util/gtk-doc-am
>=dev-util/intltool-0.35
>=app-text/gnome-doc-utils-0.9.1
test? ( dev-libs/check )
"

pkg_setup() {
use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
}

src_prepare() {
DOCS="AUTHORS ChangeLog DOCUMENTERS INTERNALS \
MAINTAINERS MAINTAINERS.old NEWS README THANKS"

rm -v lib/rb-marshal.{c,h} || die # upstream bug 737831

gnome2_src_prepare
}

src_configure() {
export GST_INSPECT=/bin/true #508124

# --enable-vala just installs the sample vala plugin, and the configure
# checks are broken, so don't enable it
# webkit support is for old and vulnerable versions
gnome2_src_configure \
MOZILLA_PLUGINDIR=/usr/$(get_libdir)/nsbrowser/plugins \
VALAC=$(type -P true) \
--enable-mmkeys \
--disable-more-warnings \
--disable-static \
--disable-vala \
--without-hal \
--without-webkit \
$(use_enable visualizer) \
$(use_enable daap) \
$(use_enable libnotify) \
$(use_enable lirc) \
$(use_enable nsplugin browser-plugin) \
$(use_enable python) \
$(use_enable upnp-av grilo) \
$(use_with cdr brasero) \
$(use_with gnome-keyring libsecret) \
$(use_with ipod) \
$(use_with mtp) \
$(use_with udev gudev)
}

src_test() {
unset SESSION_MANAGER
Xemake check
}

0 comments on commit 32f74b8

Please sign in to comment.