Skip to content

Commit

Permalink
dev-ruby/activesupport: add 4.2.11.1
Browse files Browse the repository at this point in the history
Signed-off-by: Hans de Graaff <[email protected]>
Package-Manager: Portage-2.3.62, Repoman-2.3.11
  • Loading branch information
graaff committed Mar 14, 2019
1 parent b9e6369 commit 332a232
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/activesupport/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST rails-4.2.11.1.tgz 4081006 BLAKE2B 7db84961963f529a9b6c06011bb6e32b56f4beb064de31c811a092d27e93156669ade4dcceb7d8abcdba4845d42258d904f8ecaf79198af1c0e2afcb33fe3fe3 SHA512 198fa072f3f09a9893377439ddd1803effdf04a33ae7b609234464e7de9ad960439d1b80ae62e1f9b223b3173839be7233c314a72057933b43672f390d96a8df
DIST rails-4.2.11.tgz 4080621 BLAKE2B 97f22f887255a1d8321d26040a9896cc87e0e7e50db208d3c0f96a74d926cfe9bb516641e06f7bfd92649b91427094f729d2d6b24df811ff0481c03950d3185b SHA512 df31ac9cff0b6b07113f6066b0459b40b7263356c40a722636091b75c7443691625153d8e2d7e01324e98321d757f67ba3b9318d4229a3c1a0cea5af65b6b470
DIST rails-5.1.6.1.tgz 6143808 BLAKE2B 40949c4598af98e177bab19aea809a724135a56aaec66bfdfd820412794f548da195597461d5bd7b6e07bf60a5b6aee330a0a5fdf90bc0b0361b94a80d0684b4 SHA512 118798424ba249c3a7eed3e7174ed4a25d2fb81b8f521e165b2aef995956da7c085084be3dad9961e57e67a685ec3d527c3bfa91730d1053951cdd81b7e511ff
DIST rails-5.1.6.2.tgz 6144050 BLAKE2B b204a66f97514eab94ebcfee89d55482577bf1c355b813e3e596c1d8c1a9f4167871fda75fc605c6b5801a3a247050b53b075abcf3a28bb30ec45e166d7cd8f8 SHA512 4e2e4739a276e66ace4a330b65c05c8c8465d71438b6d6d8c30051f9ff9ba6d2669c0379b2478d9a94e9535e7c079b39d6fa1b388619e7d29a3fd8d6127588fd
Expand Down
66 changes: 66 additions & 0 deletions dev-ruby/activesupport/activesupport-4.2.11.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_RUBY="ruby23 ruby24"

RUBY_FAKEGEM_TASK_DOC=""

RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem versionator

DESCRIPTION="Utility Classes and Extension to the Standard Library"
HOMEPAGE="https://github.com/rails/rails"
SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

RUBY_S="rails-${PV}/${PN}"

ruby_add_rdepend "
>=dev-ruby/i18n-0.7:0.7
>=dev-ruby/tzinfo-1.1:1
>=dev-ruby/minitest-5.1:5
>=dev-ruby/thread_safe-0.3.4:0"

# memcache-client, nokogiri, and builder are not strictly
# needed, but there are tests using this code.
ruby_add_bdepend "test? (
>=dev-ruby/dalli-2.2.1
>=dev-ruby/nokogiri-1.4.5
>=dev-ruby/builder-3.1.0
dev-ruby/rack
dev-ruby/mocha:0.14
)"

all_ruby_prepare() {
# Set the secure permissions that tests expect.
chmod 0755 "${HOME}" || die "Failed to fix permissions on home"

# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|mime-types\|sprockets\|stackprof\|rack-cache\|sqlite\)/ s:^:#:" \
-e '/:job/,/end/ s:^:#:' \
-e '/group :doc/,/^end/ s:^:#:' \
-e 's/gemspec/gemspec path: "activesupport"/' \
-e '/rake/ s/12.3/12.4/ ; /dalli/ s/2.7.7/2.7.10/' \
-e '5igem "builder"; gem "rack"' ../Gemfile || die
rm ../Gemfile.lock || die

# Avoid test that fails with Minitest 5.4 since that already defines
# a string E in its TestCase.
rm test/core_ext/marshal_test.rb || die
sed -i -e '/test_const_missing_in_anonymous_modules/askip "gentoo minitest"' test/dependencies_test.rb || die

# Avoid test crashing newer versions of minitest
rm -f test/autoload_test.rb test/core_ext/object/json_cherry_pick_test.rb test/core_ext/object/json_gem_encoding_test.rb || die
}

0 comments on commit 332a232

Please sign in to comment.