Skip to content

Commit

Permalink
games-board/stockfish: version bump to 9
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
tamiko committed Feb 7, 2018
1 parent 7643ec7 commit 33377fc
Show file tree
Hide file tree
Showing 3 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-board/stockfish/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST stockfish-8-src.zip 159017 BLAKE2B 01f2bf017a3e822e9a1cc35b3fd3a05a1e25e3acbc51b4b8ad9d9447eb5e35a8f8e313f72b4353e5ce1937ceb0aeb581a35d393e593fd0dd9851f149ea658b73 SHA512 4dcc8c6e975367e96d5b4e76c241094e1bade53fd19fa29320a5df10177ff5ae04844ca7ae9f9cfe929aa1341d898aabbbe523bbdab4c5beef75ca8332ce50c1
DIST stockfish-9-src.zip 171925 BLAKE2B dacfe02525e2d78bf91a41bf2d22077ecb808566f87317382515aa14baade2c03c150ecd62ae026c5883321642330cd9beab50df35db3f1c7de18c8b84922ae0 SHA512 47b5dfea9e015dd68e33c8b1a131ed83710e4e5d67abe0c278a423f2940b07c7a5d661ce27915257ae3dad83fc2bb8e50d3d28bfa11a7c4cdf396d0378cd80f8
69 changes: 69 additions & 0 deletions games-board/stockfish/stockfish-9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs

DESCRIPTION="Free UCI chess engine, claimed to be the strongest in the world"
HOMEPAGE="http://stockfishchess.org/"

SRC_URI="https://stockfish.s3.amazonaws.com/${P}-src.zip"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="armv7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
general-32 general-64 +optimize"

DEPEND="|| ( app-arch/unzip app-arch/zip )"
RDEPEND=""

S="${WORKDIR}/src"

src_prepare() {
default

# prevent pre-stripping
sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile \
|| die 'failed to disable stripping in the Makefile'
}

src_compile() {
local my_arch

# generic unoptimized first
use general-32 && my_arch=general-32
use general-64 && my_arch=general-64

# x86
use x86 && my_arch=x86-32-old
use cpu_flags_x86_sse && my_arch=x86-32

# amd64
use amd64 && my_arch=x86-64
use cpu_flags_x86_popcnt && my_arch=x86-64-modern

# both bmi2 and avx2 are part of hni (haswell new instructions)
use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2

# other architectures
use armv7 && my_arch=armv7
use ppc && my_arch=ppc
use ppc64 && my_arch=ppc64

# Skip the "build" target and use "all" instead to avoid the config
# sanity check (which would throw a fit about our compiler). There's
# a nice hack in the Makefile that overrides the value of CXX with
# COMPILER to support Travis CI and we abuse it to make sure that we
# build with our compiler of choice.
emake all ARCH="${my_arch}" \
COMP=$(tc-getCXX) \
COMPILER=$(tc-getCXX) \
debug=$(usex debug "yes" "no") \
optimize=$(usex optimize "yes" "no")
}

src_install() {
dobin "${PN}"
dodoc ../AUTHORS ../Readme.md
}
1 change: 1 addition & 0 deletions media-sound/quodlibet/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST quodlibet-3.7.1.tar.gz 3651908 BLAKE2B dd221aae3af83e7f7b1c535c5294a5262b8b08bb7ac068078fb3be1b1c6a3a8770dda20b6a03b3fd998bac17f1087b748d5fd1fe3b7f010ee107283b2170b452 SHA512 73f2a909e29178fb4074dbf451a6d04170aebecb7934248b04b909f9639c9098054eefe3343cfb67cc3c622f6d453b5417e5233d4d2ec9c87c48a0c5b4debf4f
DIST quodlibet-3.8.1.tar.gz 3697363 BLAKE2B 67c56281a998d93b2ea457656473ab7fc45a1d4d80aa561fc1946e129ac91a01c65fdb34bd314b5742756708714ac043341cae6ee38e93e37a7a16e3bf481c20 SHA512 5f8f7ba3157dea83782c64989114ad38295c660300284b72e825eba46eae053120c96e60518d573b4010dd49e396a4fe8d04788e632e61e38fa6edd953014275
DIST quodlibet-3.9.1.tar.gz 3850929 BLAKE2B c4317521259f1d46e927276ee8bd927afd72708f7b6e260a68e2cfe6e949f44e08df5884f3613804955b18b7284f0140f9d2d409833bd0a139732728903ae978 SHA512 6d6b6380de2fc2d3ab1614b304f2d7219ff1d823e03f532baa0e9b1308fd36094ad745433494253d956182ae9914eb62846df3d3e5fea92dddccdaa725178563
DIST quodlibet-4.0.2.tar.gz 4730188 BLAKE2B abe5cdbb6302bf381a7426145c25f6c1e205a2be8ffd801b93ed47e0a23764c142b59cd8de001458ef378fe70523308035517b82bfacbc1213eb7f4a86dcdb7d SHA512 c8c1f823ace03f69fab848f8e312edf9aa1e1e417a843ad2e08d75a0e26a0e095b7050e737be450e5b0b72c7c51b16d1d2143e297dde67bae310b9cdb6f85e3b

0 comments on commit 33377fc

Please sign in to comment.