Skip to content

Commit

Permalink
dev-php/PEAR-Archive_Tar: Version bump for 1.4.14
Browse files Browse the repository at this point in the history
Signed-off-by: Brian Evans <[email protected]>
  • Loading branch information
Brian Evans committed Jul 21, 2021
1 parent 50c7026 commit 3349b6f
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/PEAR-Archive_Tar/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST Archive_Tar-1.4.12.tgz 21665 BLAKE2B fc4d2d5128bfc02da5f7e2465834e2ff14554188ede7899856f200935a850c35bb74e6fcca5c4c4ae641a575725a3edba2878376a587304f133c8f16e1ee9336 SHA512 9f2e6ca4628ba4ec95a324c4a706b2d01d2323b5e5e77f1cc7425784d1a35d139b1604bffca10af8b04c4cc875cb6b1f40715a00208cd042aba37f089a586497
DIST Archive_Tar-1.4.13.tgz 21836 BLAKE2B b150c7493995c889bd91d24fb7bc5374be6ae157e27522a0d1e5b8fa994a09fdd7a03288263d0931f1d46da3e1b37c80e67cee07d5f54f501531b2adb7f4bb8a SHA512 3ee3dd8c8c8af018eb6c6d32409f2867c49f5a8ef21efecd8fb0a36207ca211eb49aaef02806b2df35aa6613d5dd69c8d81c72f97d4297dee3f732a9ab6ff9a7
DIST Archive_Tar-1.4.14.tgz 21992 BLAKE2B e483ee9943c955dd6834538de70e8d6821b9abb250fca752e01fec7a62c28f59f65a6afe66adb804565c1f79cfc679fd72a32d0311f231dee424199b2600bb73 SHA512 a0277086221acf0cd01ec342af5afd62f01055a8b3bb4942d7a96d3517cce466a0c8a086411671a18d0f7a0a5e4187a76bad0d5c410c93fefe8cc58992327789
50 changes: 50 additions & 0 deletions dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MY_PN="${PN/PEAR-/}"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="Tar file management class"
HOMEPAGE="https://pear.php.net/package/Archive_Tar"
SRC_URI="https://pear.php.net/get/${MY_P}.tgz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE=""

# bzip2 and zlib are needed for compressed tarballs, and there's one
# call to preg_match to test paths against a pattern of files and
# directories that will be ignored.
RDEPEND="dev-lang/php:*[bzip2,pcre(+),zlib]"
PDEPEND="dev-php/PEAR-PEAR"
DEPEND=""

S="${WORKDIR}/${MY_P}"

src_install() {
insinto /usr/share/php
doins -r Archive

dodoc docs/*

insinto /usr/share/php/.packagexml
newins "${WORKDIR}/package.xml" "${MY_P}.xml"
}

pkg_postinst() {
# It is not critical to complete so only warn on failure
if [[ -f "${EROOT}/usr/share/php/.packagexml/${MY_P}.xml" && \
-x "${EROOT}/usr/bin/peardev" ]] ; then
"${EROOT}/usr/bin/peardev" install -nrO --force \
"${EROOT}/usr/share/php/.packagexml/${MY_P}.xml" 2> /dev/null \
|| ewarn "Failed to insert package into local PEAR database"
fi
}

pkg_postrm() {
if [[ -x "${EROOT}/usr/bin/peardev" ]]; then
"${EROOT}/usr/bin/peardev" uninstall -nrO "pear.php.net/${MY_PN}"
fi
}

0 comments on commit 3349b6f

Please sign in to comment.