Skip to content

Commit

Permalink
sys-libs/libsepol: bump to 2.6-rc1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
perfinion committed Oct 3, 2016
1 parent e2948f9 commit 335085f
Show file tree
Hide file tree
Showing 3 changed files with 51 additions and 1 deletion.
1 change: 1 addition & 0 deletions sys-libs/libsepol/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libsepol-2.5.tar.gz 438730 SHA256 2bdeec56d0a08b082b93b40703b4b3329cc5562152f7254d8f6ef6b56afe850a SHA512 ea781a9a61ee7036abd221422f411451e15d01202de64b167c61886644d6e9ec81916dd770bc644ba2453ff177ac91f280be63df0e20b469b4f778ce3bfdedd9 WHIRLPOOL f1a4614eae84cd07eb909c88342628d5abd3db6123907c437c680e39930137f5d07f91ce46353fbd73f42d97126f1b70dffba814d791f3931e116daf391f4531
DIST libsepol-2.6-rc1.tar.gz 441953 SHA256 467e69a1937effeac24c5a3dbdd76bc9967d83bd80deaa95bd28cee8cadda063 SHA512 3ec5627bf525a3499fb19464fc412c5ac2326365899b72b18d8d754003c34c1ac300c0fe359ae9e8f5ac3466a1c9c096716aa78ca00e31c6c78ee02ef62d822c WHIRLPOOL 0b0b61bccb6a018266998e43ae77908900775c291f3316a11fda697fbd91b2b9a8c3a1d7ee084b70ca9348c5b6ca23a0e9719cbd5972424d94b7c820ce51812c
49 changes: 49 additions & 0 deletions sys-libs/libsepol/libsepol-2.6_rc1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="6"

inherit multilib toolchain-funcs multilib-minimal

MY_P="${P//_/-}"
MY_RELEASEDATE="20160930"

DESCRIPTION="SELinux binary policy representation library"
HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
S="${WORKDIR}/${MY_P}/${PN}"
else
SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
S="${WORKDIR}/${MY_P}"
fi

LICENSE="GPL-2"
SLOT="0"
IUSE=""

DEPEND=""
RDEPEND=""

# tests are not meant to be run outside of the full SELinux userland repo
RESTRICT="test"

src_prepare() {
eapply_user
multilib_copy_sources
}

multilib_src_compile() {
tc-export RANLIB;
LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
emake AR="$(tc-getAR)" CC="$(tc-getCC)"
}

multilib_src_install() {
LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
emake DESTDIR="${D}" install
}
2 changes: 1 addition & 1 deletion sys-libs/libsepol/libsepol-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ EAPI="6"
inherit multilib toolchain-funcs multilib-minimal

MY_P="${P//_/-}"
MY_RELEASEDATE="20150202"
MY_RELEASEDATE="20160930"

DESCRIPTION="SELinux binary policy representation library"
HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
Expand Down

0 comments on commit 335085f

Please sign in to comment.