Skip to content

Commit

Permalink
media-libs/libraw: Bump to version 0.18.12
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
Lars Wendler committed Jun 19, 2018
1 parent e914e9a commit 3385475
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/libraw/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST LibRaw-0.18.11.tar.gz 1283643 BLAKE2B cd217a0c40d0f30ff95968c5238ad349d32f6ae44aca3847b32c236e8e82e7ff25ba5d6bb0cffe8d73b288239830982d074a306b682160bfe8c73b0df9fcff09 SHA512 4d114bdb589c96d95f646b1d016cfb9546ea7a53b9f23af1dc5d0e38cb4d1b2aa7270f2d4dbe7c6c323fb7f21403914a0bb75afa7b6204d0a99c72ecf0c812c9
DIST LibRaw-0.18.12.tar.gz 1283491 BLAKE2B a0e23bf58ecf331ef52e529be5dd27acf8458d1a6de700b36df6172b7cfde2da62561e29c197bc360237b12c7a427b1d07a0c64862fe1cead461a6989e488218 SHA512 8fcf1e24295457f09a654a14d77869ca401a21e9f4386d91fb0fd5bc9aa20a882bf490a64c183108e645b5fa70401f97868c83837a057cb707f58fa31a417d44
DIST LibRaw-0.18.4.tar.gz 1281104 BLAKE2B dc6c2b594f0897eea509d3122bd7f41bccd89182a5e294b331544ad626631f18637660e1de7ea1c8b5e1c0b59678189d06f9fd12e27016e2ea3ec736cabfbbe4 SHA512 e71db23a70f0cda745ae862f4cb6a0c51c968e4c7399f28e86de8beb894526fa76cd337c1406e2eaee3f287f15e8912d1a0f7217493c6444a491ca3329f63776
DIST LibRaw-0.18.8.tar.gz 1281773 BLAKE2B 755d17ee4c08e26b04d20cc6284f43e1a87d2bc1b41499d175c6ebfc39684732a4407b990115818553c7b815c66bb04ad451d478ed2c084c443871de8ea221e4 SHA512 48871a5e43c89a17962fae426a962d11a6ce40cb8e7d8abc90e98c899dc42b7e1711398c075901ddbc710fe7e916ba6d507bee7e18975779caa8f5d512b1d580
DIST LibRaw-0.18.9.tar.gz 1282015 BLAKE2B d94681633e3b187102462be5b849cb4cb3468a74d5c4288e23a07ccf0b66246305f9e75e1d6408e259b3c7777ef77501954d208669c9ddc56b943f13f95c867e SHA512 5becbbf05db091d86f7a3a098402c5a981a5c614e9ac742e80823efec5dccfb3a1336cfd1493aa88c8d1a37fe05896efd3f8f145536d799a9ce19665073cf8ce
Expand Down
66 changes: 66 additions & 0 deletions media-libs/libraw/libraw-0.18.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit multilib-minimal toolchain-funcs

MY_PN=LibRaw
MY_PV="${PV/_b/-B}"
MY_P="${MY_PN}-${MY_PV}"
# demosaic package sometimes doesn't get bumped.
# Otherwise you can set it to ${PV}.
DEMOSAIC_PV="0.18.8"

DESCRIPTION="LibRaw is a library for reading RAW files obtained from digital photo cameras"
HOMEPAGE="https://www.libraw.org/ https://github.com/LibRaw/LibRaw"
SRC_URI="https://www.libraw.org/data/${MY_P}.tar.gz
demosaic? (
https://www.libraw.org/data/LibRaw-demosaic-pack-GPL2-${DEMOSAIC_PV}.tar.gz
https://www.libraw.org/data/LibRaw-demosaic-pack-GPL3-${DEMOSAIC_PV}.tar.gz
)"

LICENSE="LGPL-2.1 CDDL demosaic? ( GPL-2 GPL-3 )"
SLOT="0/16" # subslot = libraw soname version
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="demosaic examples jpeg jpeg2k +lcms openmp"

RDEPEND="jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
jpeg2k? ( >=media-libs/jasper-1.900.1-r6:=[${MULTILIB_USEDEP}] )
lcms? ( >=media-libs/lcms-2.5:2[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
virtual/pkgconfig"

S="${WORKDIR}/${MY_P}"

DOCS=( Changelog.txt README )

pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}

pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}

multilib_src_configure() {
local myeconfargs=(
--disable-static
$(use_enable demosaic demosaic-pack-gpl2)
$(use_enable demosaic demosaic-pack-gpl3)
$(use_enable examples)
$(use_enable jpeg)
$(use_enable jpeg2k jasper)
$(use_enable lcms)
$(use_enable openmp)
)
ECONF_SOURCE="${S}" \
econf "${myeconfargs[@]}"
}

multilib_src_install_all() {
einstalldocs

# package installs .pc files
find "${D}" -name '*.la' -delete || die
}

0 comments on commit 3385475

Please sign in to comment.