Skip to content

Commit

Permalink
net-misc/aria2: Bump to 1.28.0
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Oct 16, 2016
1 parent 7c88a4d commit 3387da4
Show file tree
Hide file tree
Showing 2 changed files with 151 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/aria2/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST aria2-1.25.0.tar.xz 1493880 SHA256 ff89eb4c76cfc816a6f5abc7dfd416cc3f339e7d
DIST aria2-1.26.0.tar.xz 1496396 SHA256 c828f3375e9ab251239747fbbbf747e5027339080b9fdec29ac746a0b8c6088d SHA512 f87875c0740df054f44018431cff6e215f48a2458278be740b4cd7baa5723e8ed52215ea8c7c54944324f942bfe5c0ca7a532a9eb39eca3428a2f2d58e0ca0f0 WHIRLPOOL 4bfe87985775c547d86ad99ae1315e45c466b5ba00ea49e4a2b851621ae332833e55f86af764f96e3b408302ad8eccdeb00313b34b95a9e90f86503569f3cf88
DIST aria2-1.26.1.tar.xz 1494864 SHA256 f4e64e9754af5e1c0ee1ee2a50c5fa5acbc180855909209c2ce0111e86c9a801 SHA512 1a96451ed72a557cddd605f2362c40b0db40878f3a40ce6898c95257178a2c04d5570354ac28dd4d451ed2931eb6bc86fb9addab6b0fd60857d026aae691e683 WHIRLPOOL 2e551bbd1af6d14ba396b26ee650dab7b89f258ca9cf84b90e09365fef80f944933fa1c0b1cf1bc5e3154c780b9fa3b08427c4efb9e4eded6c6c5559024a002b
DIST aria2-1.27.1.tar.xz 1489132 SHA256 c09627ef31602cfdfa7c9925a6c3b05fe7d2097d83f42dcfdef68664bd106f08 SHA512 baeb637a231907c3f0f752c46038442745cb2cf224d696727ff567d20f3a9a6a002fca3604a90030dfd4d19ff306fe47d27d37a1e32e55fa0e9cd350c2c624a3 WHIRLPOOL 35620a2057394f8cd21479011f7ad6d663eab1aa230778707b0c5feca46f23a4f80922181fb186464b3b0ed5de4807df5b53e2b9226d110118ce647dc8b2a2f5
DIST aria2-1.28.0.tar.xz 1495984 SHA256 e0a125a557b9aacf23468374f63215e9b1d6165c990bd8ecb0603cdc1d5d72f0 SHA512 d0a534eadfa7c522fc709a7b54849990e6346263ac9997d15945c0949bee468829b000807fc1ef3a1289fa13eb092461f4c9c7da5b64792078e683bd5942f135 WHIRLPOOL 60110a72accdd9fbde534cad929ed70adff9c837d8cf6be40d1a59c78a22e1ee75318acee1a422b58365567fb38c68f3cabe383f0f02190e54ad2ea88bf5776d
150 changes: 150 additions & 0 deletions net-misc/aria2/aria2-1.28.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,150 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="6"

inherit bash-completion-r1

DESCRIPTION="A download utility with segmented downloading with BitTorrent support"
HOMEPAGE="http://aria2.sourceforge.net/"
SRC_URI="https://github.com/tatsuhiro-t/${PN}/releases/download/release-${PV}/${P}.tar.xz"

LICENSE="GPL-2"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
SLOT="0"
IUSE="adns bittorrent +gnutls jemalloc libuv +libxml2 metalink +nettle nls sqlite scripts ssh ssl tcmalloc test xmlrpc"

CDEPEND="sys-libs/zlib:0=
ssl? (
app-misc/ca-certificates
gnutls? ( >=net-libs/gnutls-1.2.9:0= )
!gnutls? ( dev-libs/openssl:0= ) )
adns? ( >=net-dns/c-ares-1.5.0:0= )
bittorrent? (
ssl? (
gnutls? (
nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-5:0= )
!nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
!ssl? (
nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-5:0= )
!nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
jemalloc? ( dev-libs/jemalloc )
libuv? ( dev-libs/libuv:0= )
metalink? (
libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
!libxml2? ( dev-libs/expat:0= ) )
sqlite? ( dev-db/sqlite:3= )
ssh? ( net-libs/libssh2:= )
tcmalloc? ( dev-util/google-perftools )
xmlrpc? (
libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
!libxml2? ( dev-libs/expat:0= ) )"

DEPEND="${CDEPEND}
app-arch/xz-utils
virtual/pkgconfig
nls? ( sys-devel/gettext )
test? ( >=dev-util/cppunit-1.12.0:0 )"
RDEPEND="${CDEPEND}
nls? ( virtual/libiconv virtual/libintl )
scripts? ( dev-lang/ruby )"

REQUIRED_USE="jemalloc? ( !tcmalloc )
tcmalloc? ( !jemalloc )"
RESTRICT="!test? ( test )"

pkg_setup() {
if use scripts && use !xmlrpc && use !metalink; then
ewarn "Please note that you may need to enable USE=xmlrpc to run the aria2rpc"
ewarn "and aria2mon scripts against the local aria2."
fi
}

src_prepare() {
default
sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
}

src_configure() {
local myconf=(
# threads, epoll: check for best portability

# do not try to compile and run a test LIBXML program
--disable-xmltest
# enable the shared library
--enable-libaria2
# zlib should always be available anyway
--with-libz
--with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt"

# optional features
$(use_enable bittorrent)
$(use_enable metalink)
$(use_enable nls)
$(use_with sqlite sqlite3)
$(use_with adns libcares)
$(use_with libuv)
$(use_with jemalloc)
$(use_with tcmalloc)
)

# SSL := gnutls / openssl
# USE=ssl
# + USE=gnutls -> gnutls
# + USE=-gnutls -> openssl

if use ssl; then
myconf+=( $(use_with gnutls) $(use_with !gnutls openssl) )
else
myconf+=( --without-gnutls --without-openssl )
fi

# message-digest := nettle / gcrypt / openssl
# bignum := nettle+gmp / gcrypt / openssl
# bittorrent := message-digest + bignum
# USE=bittorrent
# + USE=(ssl -gnutls) -> openssl
# + USE=nettle -> nettle+gmp
# + USE=-nettle -> gcrypt

if use !bittorrent || use ssl && use !gnutls; then
myconf+=( --without-libgcrypt --without-libnettle --without-libgmp )
else
myconf+=( $(use_with !nettle libgcrypt)
$(use_with nettle libnettle) $(use_with nettle libgmp) )
fi

# metalink+xmlrpc := libxml2 / expat
# USE=(metalink || xmlrpc)
# + USE=libxml2 -> libxml2
# + USE=-libxml2 -> expat

if use metalink || use xmlrpc; then
myconf+=( $(use_with !libxml2 libexpat) $(use_with libxml2) )
else
myconf+=( --without-libexpat --without-libxml2 )
fi

# Note:
# - always enable gzip/http compression since zlib should always be available anyway
# - always enable epoll since we can assume kernel 2.6.x
# - other options for threads: solaris, pth, win32
econf "${myconf[@]}"
}

src_install() {
default
rm -rf "${D}"/usr/share/doc/aria2 \
"${D}"/usr/share/doc/${PF}/README{,.html}

dobashcomp doc/bash_completion/aria2c
use scripts && dobin doc/xmlrpc/aria2{mon,rpc}
}

pkg_postinst() {
if use xmlrpc || use metalink; then
elog "If you would like to use the additional aria2mon and aria2rpc tools,"
elog "you need to have \033[1mdev-lang/ruby\033[0m installed."
fi
}

0 comments on commit 3387da4

Please sign in to comment.