Skip to content

Commit

Permalink
dev-python/PyQtWebEngine: add 5.15.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Davide Pesavento <[email protected]>
  • Loading branch information
Pesa committed Oct 21, 2021
1 parent 1b3042a commit 33b532f
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/PyQtWebEngine/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST PyQtWebEngine-5.15.4.tar.gz 49022 BLAKE2B 0ac0b3424f22aabbfd733f2a876e502f133c81f639fbd87a4c7509865635b29d4bd3596ccc151b0919a28eff0015913c4fae1a831dbe774fe2d2aeee732e469b SHA512 25cf8578ffae8adbc1dd8d914921b4edf91f19fcf983c9c83c9c8934b4e918ba27bd34a6b9c8252773ec32e6f1f13a06f22cf7d7326a5aceaa91530ea4ee047e
DIST PyQtWebEngine-5.15.5.dev2108100905.tar.gz 49043 BLAKE2B 01b75db0d9fa973ccd0a85f9336e16b7c1fb2a303a0d004d247f91744dc642edb836597877fce6c4f038afa6f87ba066eeaca1e3d467bc15689dbe82e8a9809e SHA512 1ea407832f062dc9b9a6c6312feb4c8f3553b55972e5a32c70c9d1c278918d32934791d60c022a56ab507b6215d5f78e1b4244b9fffa3256aad1f5f4afebd47a
DIST PyQtWebEngine-5.15.5.tar.gz 48610 BLAKE2B ea266c09965a6ee62e33d3970b145068271c9e1eb87839782e0100b5db2e90a0c002fc4d6f3d22ef9a5cb8c42a067bb45008b0392a0d8557bc6c5c9d77e6b75a SHA512 20eecd479ea757e3bf9855c7dafe0bbbc0cbc61be26509605a5c9a8026e54bb6e362069ecf4be74733dcf6eec154f6ed13933e334e4455b080e687abfd2659fa
76 changes: 76 additions & 0 deletions dev-python/PyQtWebEngine/PyQtWebEngine-5.15.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
inherit python-r1 qmake-utils

DESCRIPTION="Python bindings for QtWebEngine"
HOMEPAGE="https://www.riverbankcomputing.com/software/pyqtwebengine/ https://pypi.org/project/PyQtWebEngine/"

MY_P=${PN}-${PV/_pre/.dev}
if [[ ${PV} == *_pre* ]]; then
SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
fi
S=${WORKDIR}/${MY_P}

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="debug"

REQUIRED_USE="
${PYTHON_REQUIRED_USE}
"

DEPEND="${PYTHON_DEPS}
>=dev-python/PyQt5-5.15.5[gui,network,printsupport,ssl,webchannel,widgets,${PYTHON_USEDEP}]
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwebengine:5[widgets]
"
RDEPEND="${DEPEND}
>=dev-python/PyQt5-sip-12.9:=[${PYTHON_USEDEP}]
"
BDEPEND="
>=dev-python/PyQt-builder-1.10[${PYTHON_USEDEP}]
>=dev-python/sip-6.2[${PYTHON_USEDEP}]
dev-qt/qtcore:5
"

src_configure() {
configuration() {
local myconf=(
sip-build
--verbose
--build-dir="${BUILD_DIR}"
--scripts-dir="$(python_get_scriptdir)"
--qmake="$(qt5_get_bindir)"/qmake
--no-make
$(usev debug '--debug --qml-debug --tracing')
)
echo "${myconf[@]}"
"${myconf[@]}" || die

# Run eqmake to respect toolchain and build flags
run_in_build_dir eqmake5 -recursive ${PN}.pro
}
python_foreach_impl configuration
}

src_compile() {
python_foreach_impl run_in_build_dir default
}

src_install() {
installation() {
emake INSTALL_ROOT="${D}" install
python_optimize
}
python_foreach_impl run_in_build_dir installation

einstalldocs
}

0 comments on commit 33b532f

Please sign in to comment.