forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
lxqt-base/lxqt-notificationd: Version bump to 0.11.0
Package-Manager: portage-2.3.2
- Loading branch information
Showing
2 changed files
with
40 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST lxqt-notificationd-0.10.0.tar.xz 30896 SHA256 5c0859157ff6a20d613ea4aca24e786faf79ab6d69afec1e0b3671e3bbda53d5 SHA512 3a3ebcc104ac6de3c11ceac8a0c6b8f942e824b1301413fa20f93be68d53e02747e8c478fc744fa1bd3f04d2f54cd042c4b538cd537626d8b69088274a323519 WHIRLPOOL 56e93e04aa5ec5f81b6d6f43fdcb2ccebb429505372f51e18d28c19432133eb2a3f701ae7bda121c9474bfe7c9063c643fd470e69e2e88b9c1904ce542fc1a06 | ||
DIST lxqt-notificationd-0.11.0.tar.xz 30592 SHA256 2e57b4f0c68694a8faf4999039b039f13291c720017b14c0bbdd8e0b49a0fa82 SHA512 f6dd3463ac993d7c7743addd6924dc8f15717f658c576c78ad01e4db361d1f1c98d02f6a2bec0069c191ad923b1ff63d49faf6ff7d564f67030233d6979adec5 WHIRLPOOL ee73ff0223d1009b0c78301857997deecee9b8a5f563a5d6bc7f0f29220d502e076abe9156a350ce59e568ea50188081a947b6e8baf3365e6257a7287c8b8e13 |
39 changes: 39 additions & 0 deletions
39
lxqt-base/lxqt-notificationd/lxqt-notificationd-0.11.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit cmake-utils | ||
|
||
DESCRIPTION="LXQt notification daemon and library" | ||
HOMEPAGE="http://lxqt.org/" | ||
|
||
if [[ ${PV} = *9999* ]]; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git" | ||
else | ||
SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
fi | ||
|
||
LICENSE="GPL-2 LGPL-2.1+" | ||
SLOT="0" | ||
|
||
RDEPEND=" | ||
>=dev-libs/libqtxdg-1.0.0 | ||
dev-qt/qtcore:5 | ||
dev-qt/qtdbus:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtwidgets:5 | ||
dev-qt/qtx11extras:5 | ||
dev-qt/qtxml:5 | ||
kde-frameworks/kwindowsystem:5 | ||
~lxqt-base/liblxqt-${PV} | ||
=lxqt-base/lxqt-common-0.11*" | ||
DEPEND="${RDEPEND} | ||
dev-qt/linguist-tools:5" | ||
|
||
src_configure() { | ||
local mycmakeargs=( -DPULL_TRANSLATIONS=OFF ) | ||
cmake-utils_src_configure | ||
} |