Skip to content

Commit

Permalink
media-gfx/qimgv: version bump 0.7.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.51-r1, Repoman-2.3.11
Signed-off-by: Jiayi Zhao <[email protected]>
Closes: gentoo#10824
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
kamiyaa authored and a17r committed Feb 28, 2019
1 parent 72fb74e commit 33cd78b
Show file tree
Hide file tree
Showing 3 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/qimgv/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST qimgv-0.7.1.tar.gz 273529 BLAKE2B 60f1f87c3347333f76224046776ca4303a03286593191feb18791dd7065ba714db387a1f8cbf6f16f04cab7190645edee4aba11f13d1ce6c0cb52d9b79042f18 SHA512 dd142377aca7248d00ac51d0732de94106e7471973de45d66e8905c476e5eb5f3543e98b1322390dc54946e7c518c1a8711bcde46fb67c376808e4049b22a630
DIST qimgv-0.7.3.tar.gz 266307 BLAKE2B b13794f4bd7ff8b2c9309f95453baa65f91c60d155e22a86eac1eb79b3dc7f9da003dbfdbfc2d14cbb6242c769516283785ed72e2f50d5bb51b394db05c167b8 SHA512 fae7986ce29941232dd2863a0900651fb3a7d6d184b05e763670b16c74bb0cc27ce6eb936b2a41a2183e3dc5c33006e3fe3491ed043c6e357ea31d6a716d80e0
1 change: 1 addition & 0 deletions media-gfx/qimgv/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -12,5 +12,6 @@

<use>
<flag name="video">Add support for gif/webm playback via libmpv</flag>
<flag name="blur">Add support for background blur</flag>
</use>
</pkgmetadata>
52 changes: 52 additions & 0 deletions media-gfx/qimgv/qimgv-0.7.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils gnome2-utils xdg-utils

DESCRIPTION="A cross-platform image viewer with webm support. Written in qt5"
HOMEPAGE="https://github.com/easymodo/qimgv"
SRC_URI="https://github.com/easymodo/qimgv/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="kde video"

RDEPEND="
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
kde? ( kde-frameworks/kwindowsystem:5 )
video? ( media-video/mpv[libmpv] )
"
DEPEND="
${RDEPEND}
virtual/pkgconfig
"

src_prepare() {
cmake-utils_src_prepare
# respect make.conf CXXFLAGS
sed -i -e '/set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -O3")/d' CMakeLists.txt || die
}

src_configure() {
local mycmakeargs=(
-DKDE_SUPPORT=$(usex kde)
-DVIDEO_SUPPORT=$(usex video)
)
cmake-utils_src_configure
}

pkg_postinst() {
gnome2_icon_cache_update
xdg_desktop_database_update
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_desktop_database_update
}

0 comments on commit 33cd78b

Please sign in to comment.