Skip to content

Commit

Permalink
sys-kernel/vanilla-kernel: Bump to 5.4.168
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Dec 23, 2021
1 parent f98816a commit 33d11a7
Show file tree
Hide file tree
Showing 2 changed files with 109 additions and 0 deletions.
2 changes: 2 additions & 0 deletions sys-kernel/vanilla-kernel/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -37,3 +37,5 @@ DIST linux-5.4.166.tar.sign 991 BLAKE2B 0051ff905ade9e7c4c5089602f940d643301e6f4
DIST linux-5.4.166.tar.xz 109194364 BLAKE2B 531351c5ef90466073bdf19ddc4eb7ababb87c8343c10c9c61c236bb96c47524935733d25603781ec4412fedef8fe8ebffcec893b4283fc91181ec3201b29acb SHA512 5550095b77209f33e799ce1fd8d85289ce9b76315e50d3b1216e581457d279c7763df050e8a2e78748de87da4f5aefcdc4e437f3c54ffea86c026a0caa4f08aa
DIST linux-5.4.167.tar.sign 991 BLAKE2B ba73a1a1aebaa749ba6b1f61fccb03712b7d6f179b125b54436f485c5e7b943157aa6ac86ba0c9277a245539c276901eb5e102ee776cd3f7c4a92db3c721241b SHA512 41ed244c64d402c16bd57afa4746e262e5b1d0329d99f3dccd617af6fbfa43b340fd66789f0816ff4d7c5cbe04173c1ee04bd6c7eeb751049e7272913b3b33c1
DIST linux-5.4.167.tar.xz 109196336 BLAKE2B 39e609668244c2a429bea0096bf4a39325753461995c4fc7077d1f49741952f47e79b37b191a6b9f830d01cbe5594f84203b26799cc1fb6f802c8143d3924bd2 SHA512 46f66116f91cecde3f4991b00a8678ab505919802106a932a80923154f8e92b82cc21aab3dfa1e5d58da718a17eb2d99378c4027cd6557d729942e14e076cc7a
DIST linux-5.4.168.tar.sign 991 BLAKE2B a581b74de0296ef69cd10686381571aa3c2e73b59dd495e78a7ba168dff85f7af3a3b7719419b767fe0b8380a904248d624bd1e17712327d2ebd62335943f8dd SHA512 bdd0a88b6199d57b3c86521e58a356a35273007fb421e5d3b80d40e4b9337c30fa1b982dba61673fda0ddc9e3107b8da5cbe4916364fbbe035ab5026befe1c74
DIST linux-5.4.168.tar.xz 109188452 BLAKE2B 72e7da0a2a2d2ecef4b73b268db09a7cdb7a0e76cbbbfd7111ec727593f8eb60026ecd8102bedf9b13b393cfc9fdd4b5297ed4c48869152c09581d763e156552 SHA512 119856b47f2fb2d3560fedb60fc3dd432e5b150261c9d959e5e9426f7f6e03630fcade800b8e97fe6fc6edc717bc6a0a296c875c0dc771045b65d20b9df8a510
107 changes: 107 additions & 0 deletions sys-kernel/vanilla-kernel/vanilla-kernel-5.4.168.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,107 @@
# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit kernel-build verify-sig

MY_P=linux-${PV}
# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
CONFIG_VER=5.4.21
CONFIG_HASH=2809b7faa6a8cb232cd825096c146b7bdc1e08ea
GENTOO_CONFIG_VER=5.4.114

DESCRIPTION="Linux kernel built from vanilla upstream sources"
HOMEPAGE="https://www.kernel.org/"
SRC_URI+="
https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
https://github.com/mgorny/gentoo-kernel-config/archive/v${GENTOO_CONFIG_VER}.tar.gz
-> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
verify-sig? (
https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.sign
)
amd64? (
https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-x86_64.config
-> kernel-x86_64.config.${CONFIG_VER}
)
arm64? (
https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-aarch64.config
-> kernel-aarch64.config.${CONFIG_VER}
)
ppc64? (
https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-ppc64le.config
-> kernel-ppc64le.config.${CONFIG_VER}
)
x86? (
https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-i686.config
-> kernel-i686.config.${CONFIG_VER}
)"
S=${WORKDIR}/${MY_P}

LICENSE="GPL-2"
KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
IUSE="debug"

RDEPEND="
!sys-kernel/vanilla-kernel-bin:${SLOT}"
BDEPEND="
debug? ( dev-util/pahole )
verify-sig? ( sec-keys/openpgp-keys-kernel )"
PDEPEND="
>=virtual/dist-kernel-${PV}"

VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/kernel.org.asc

src_unpack() {
if use verify-sig; then
einfo "Unpacking linux-${PV}.tar.xz ..."
verify-sig_verify_detached - "${DISTDIR}"/linux-${PV}.tar.sign \
< <(xz -cd "${DISTDIR}"/linux-${PV}.tar.xz | tee >(tar -x))
assert "Unpack failed"
unpack "gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz"
else
default
fi
}

src_prepare() {
default

# prepare the default config
case ${ARCH} in
amd64)
cp "${DISTDIR}/kernel-x86_64.config.${CONFIG_VER}" .config || die
;;
arm64)
cp "${DISTDIR}/kernel-aarch64.config.${CONFIG_VER}" .config || die
;;
ppc)
# assume powermac/powerbook defconfig
# we still package.use.force savedconfig
cp "${WORKDIR}"/linux-*/arch/powerpc/configs/pmac32_defconfig .config || die
;;
ppc64)
cp "${DISTDIR}/kernel-ppc64le.config.${CONFIG_VER}" .config || die
;;
x86)
cp "${DISTDIR}/kernel-i686.config.${CONFIG_VER}" .config || die
;;
*)
die "Unsupported arch ${ARCH}"
;;
esac

echo 'CONFIG_LOCALVERSION="-dist"' > "${T}"/version.config || die
local merge_configs=(
"${T}"/version.config
"${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/base.config
)
use debug || merge_configs+=(
"${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/no-debug.config
)
[[ ${ARCH} == x86 ]] && merge_configs+=(
"${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/32-bit.config
)

kernel-build_merge_configs "${merge_configs[@]}"
}

0 comments on commit 33d11a7

Please sign in to comment.