Skip to content

Commit

Permalink
app-editors/dhex: 0.69 version bump, EAPI-7 bump, https
Browse files Browse the repository at this point in the history
2019-01-19:

0.69: this will be the final release of dhex 0.6x. I fixed a bug which caused
      the terminal to be broken. And added the functionality to start the
      hexcal from the commandline (-x).

Package-Manager: Portage-3.0.17, Repoman-3.0.2
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Mar 14, 2021
1 parent c041c9a commit 33ee4bc
Show file tree
Hide file tree
Showing 3 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-editors/dhex/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST dhex_0.68.tar.gz 58602 BLAKE2B c29d5af598b731bc415e2626e945253641ea61c8a744deaeee3f7a2e7b1636ccfb3f8b7696efd33d36fab59d59da408ff4f59b44a88a36a4d7afc27542326c9e SHA512 9397ec0574652022387f4108613f839b9262841c436079249fb325011b0a0e3c5bbd32d323f37b0f30e643f7060c1275337710c237ab68fb0c3f8096651a2421
DIST dhex_0.69.tar.gz 57362 BLAKE2B 26bfeaffc65b0f3b0193ee940da3ad866ea1354d0e5bec021a68a6c515da956500bfd7561ba675d0a67526d09b1a72e8372ee7bb52ec372f2b59249313cf77c6 SHA512 76115fd6b67bf1f61af6acfbc4dac9ac54c14aeb291de6a190aa1ffa599cf8b3e40a422ed34c237cf1f5c7406b07e38e38fb1c9c9dd36ce93d05265238060ba0
35 changes: 35 additions & 0 deletions app-editors/dhex/dhex-0.69.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MY_P=${PN}_${PV}
inherit toolchain-funcs

DESCRIPTION="ncurses-based hex-editor with diff mode"
HOMEPAGE="https://www.dettus.net/dhex/"
SRC_URI="https://www.dettus.net/${PN}/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~mips ~x86"
IUSE=""

DEPEND="sys-libs/ncurses:="
RDEPEND="${DEPEND}"

S="${WORKDIR}/${MY_P}"

PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )

src_compile() {
emake \
CC="$(tc-getCC)" \
LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)"
}

src_install() {
dobin dhex
dodoc README.txt
doman dhex.1 dhex_markers.5 dhex_searchlog.5 dhexrc.5
}
14 changes: 14 additions & 0 deletions app-editors/dhex/files/dhex-0.69-Makefile.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
--- a/Makefile
+++ b/Makefile
@@ -1,11 +1,4 @@
-CC= gcc
-LDFLAGS= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
-CPPFLAGS= -I/usr/include -I/usr/local/include -I/usr/include/ncurses -I/usr/local/include/ncurses
-CFLAGS= -O3 -Wall #-std=c99
-#CFLAGS+= -ffunction-sections -fdata-sections
-#LDFLAGS+= --gc-sections
LIBS= -lncurses
-DESTDIR= /usr/local/

OFILES=buffers.o input.o output.o machine_type.o main.o menu.o ui.o hexcalc.o search.o gpl.o configfile.o markers.o

0 comments on commit 33ee4bc

Please sign in to comment.