Skip to content

Commit

Permalink
sys-fs/dosfstools: Bump to version 4.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Feb 1, 2021
1 parent 711cc62 commit 33f44b6
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/dosfstools/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST dosfstools-4.1.tar.xz 172936 BLAKE2B d8ef617d9dbdc21318c4f43e2fd6dca1d3452ab46253b055d8fef09aa693bcf63ef58076a49f305bb21de87298bae5be6b626065dfcbd90935af68709e2c3c6a SHA512 e7a8aab34255d15e6865a7b031971352af1255134fab83389673bcc3cbd6ba255241bd2429070aeb4b927f8d7d73ccf1aeafe94566b133e88e7586897c317b78
DIST dosfstools-4.2.tar.gz 320917 BLAKE2B c55c7592aa80f1fe39e838c83e147ad7141ddd0f72c9c000ba7708ecb7287c3a92b4b52f72c8d0d1171b0f9609dfb7861bbbe475c5cbd7011151c93c2b1d3d0d SHA512 3cc0808edb4432428df8a67da4bb314fd1f27adc4a05754c1a492091741a7b6875ebd9f6a509cc4c5ad85643fc40395b6e0cadee548b25cc439cc9b725980156
38 changes: 38 additions & 0 deletions sys-fs/dosfstools/dosfstools-4.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs flag-o-matic

DESCRIPTION="DOS filesystem tools - provides mkdosfs, mkfs.msdos, mkfs.vfat"
HOMEPAGE="https://github.com/dosfstools/dosfstools"
SRC_URI="https://github.com/dosfstools/dosfstools/releases/download/v${PV}/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="compat +iconv test"
RESTRICT="!test? ( test )"

BDEPEND="
test? ( app-editors/vim-core )
iconv? ( virtual/libiconv )
"

src_configure() {
local myeconfargs=(
$(use_enable compat compat-symlinks)
$(use_with iconv)
)
econf "${myeconfargs[@]}"
}

src_install() {
default
if ! use compat ; then
# Keep fsck -t vfat and mkfs -t vfat working, bug 584980.
dosym fsck.fat /usr/sbin/fsck.vfat
dosym mkfs.fat /usr/sbin/mkfs.vfat
fi
}

0 comments on commit 33f44b6

Please sign in to comment.