Skip to content

Commit

Permalink
kde-apps/ark: 21.04.0 version bump
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Apr 24, 2021
1 parent 52e5719 commit 342b772
Show file tree
Hide file tree
Showing 2 changed files with 78 additions and 0 deletions.
1 change: 1 addition & 0 deletions kde-apps/ark/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ark-20.12.3.tar.xz 2717324 BLAKE2B 120dd525b1f6a4230dcb6307b86ff866161ba9da8a47d7a13852ebe028d0efc936b1aaaa69160329fff82d26fcb2aa4d198d09c4d1407774c1184aa7c4aaecdf SHA512 c6f3da5f3c24ad274891af99dd118d0c852382ce632abbc1273a5b6e216ecb53ef466d49d2279d3e6f0e1b088975584eadb2d2182d3819b888047c0a59ba0a7a
DIST ark-21.04.0.tar.xz 2726388 BLAKE2B 30b4a6e65051b1736527406d5f6f6b4b011f21d69e715aa5cc345da75540b880ef747d63e3682651d6d30ada1c6586872bd7fbec21441441833339ead2a0f139 SHA512 0daa37c9eafc39611dd01043af4cba3f49de57cc9fd09b222319a0c50803637e1e4f4e59d28262a49a6ef93fd225d3648ed451fed55002e9c2c6c8c3a3a1b891
77 changes: 77 additions & 0 deletions kde-apps/ark/ark-21.04.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

ECM_HANDBOOK="forceoptional"
ECM_TEST="optional"
KFMIN=5.80.0
QTMIN=5.15.2
VIRTUALX_REQUIRED="test"
inherit ecm kde.org optfeature

DESCRIPTION="File archiver by KDE"
HOMEPAGE="https://apps.kde.org/en/ark https://utils.kde.org/projects/ark/"

LICENSE="GPL-2" # TODO: CHECK
SLOT="5"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
IUSE="zip"

BDEPEND="
sys-devel/gettext
"
RDEPEND="
app-arch/libarchive:=[bzip2,lzma,zlib]
>=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtwidgets-${QTMIN}:5
>=kde-frameworks/karchive-${KFMIN}:5
>=kde-frameworks/kcompletion-${KFMIN}:5
>=kde-frameworks/kconfig-${KFMIN}:5
>=kde-frameworks/kconfigwidgets-${KFMIN}:5
>=kde-frameworks/kcoreaddons-${KFMIN}:5
>=kde-frameworks/kcrash-${KFMIN}:5
>=kde-frameworks/kdbusaddons-${KFMIN}:5
>=kde-frameworks/ki18n-${KFMIN}:5
>=kde-frameworks/kio-${KFMIN}:5
>=kde-frameworks/kitemmodels-${KFMIN}:5
>=kde-frameworks/kjobwidgets-${KFMIN}:5
>=kde-frameworks/kparts-${KFMIN}:5
>=kde-frameworks/kpty-${KFMIN}:5
>=kde-frameworks/kservice-${KFMIN}:5
>=kde-frameworks/kwidgetsaddons-${KFMIN}:5
>=kde-frameworks/kxmlgui-${KFMIN}:5
sys-libs/zlib
zip? ( >=dev-libs/libzip-1.2.0:= )
"
DEPEND="${RDEPEND}
>=dev-qt/qtconcurrent-${QTMIN}:5
"

src_configure() {
local mycmakeargs=(
$(cmake_use_find_package zip LibZip)
)

ecm_src_configure
}

src_test() {
local myctestargs=(
-E "(plugins-clirartest)"
)

ecm_src_test
}

pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "rar archive creation/extraction" app-arch/rar
optfeature "rar archive extraction only" app-arch/unar app-arch/unrar
optfeature "7-Zip archive support" app-arch/p7zip
optfeature "lrz archive support" app-arch/lrzip
optfeature "markdown support in text previews" kde-misc/markdownpart:${SLOT} kde-misc/kmarkdownwebview:${SLOT}
fi
ecm_pkg_postinst
}

0 comments on commit 342b772

Please sign in to comment.