forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-php/pecl-memcached: Version bump with php 7.0 and 7.1
Taken from github snapshot commit, not yet released Package-Manager: portage-2.3.3
- Loading branch information
Brian Evans
committed
Dec 12, 2016
1 parent
4825939
commit 343cbb4
Showing
3 changed files
with
121 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST memcached-2.2.0.tgz 70449 SHA256 17b9600f6d4c807f23a3f5c45fcd8775ca2e61d6eda70370af2bef4c6e159f58 SHA512 61207d3f8c11b0620dbcb20fb2ebb6d1fc10159a7e879ee91556a303c3dcdf3d2571e8dda5efcbed77ff779f5c9b226aa48800630b9e7781cd964126b848c356 WHIRLPOOL 1114a4c4371cfb42e3e4cb991980b32894f438abacf61c6da3dd6d9742c93e20df7691287c852c17dfe8261046227d73b1887c0b7b9c03a0e895a713005dc95a | ||
DIST pecl-memcached-3.0.0_alpha1_pre20161206.tar.gz 82102 SHA256 c9f158b8cb978495c89b615eb06098b24be0c501e757522dcc5357aeda6cb326 SHA512 c72c58223c8e780496f2fdfc727661efd5b5f3ae2a6bd2efa582591a9a8fae092ae5b89cac08e285bbe5175cb21f03168a605ad8bfefe9d290e97c613d2ba242 WHIRLPOOL cf3c8240982b26248079ceae96f56c906d9b741ec1b76d03ad4bad04a0598beea884dd0f89dbf9c12ffa487fc97062741a3ab69157440415e42367f02a2d7daa |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,55 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PHP_EXT_NAME="memcached" | ||
PHP_EXT_INI="yes" | ||
PHP_EXT_ZENDEXT="no" | ||
DOCS=( ChangeLog README.markdown ) | ||
|
||
USE_PHP="php5-6 php7-0" | ||
|
||
inherit php-ext-pecl-r3 | ||
|
||
USE_PHP="php5-6" | ||
|
||
KEYWORDS="~amd64 ~x86" | ||
|
||
DESCRIPTION="Interface PHP with memcached via libmemcached library" | ||
LICENSE="PHP-3" | ||
SLOT="0" | ||
IUSE="+session igbinary json sasl" | ||
|
||
DEPEND="php_targets_php5-6? ( | ||
>=dev-libs/libmemcached-1.0[sasl?] | ||
sys-libs/zlib | ||
dev-lang/php:5.6[session?,json?] | ||
igbinary? ( dev-php/igbinary[php_targets_php5-6?] ) | ||
)" | ||
RDEPEND="${DEPEND}" | ||
PDEPEND="php_targets_php7-0? ( dev-php/pecl-memcached:7[php_targets_php7-0] )" | ||
|
||
src_prepare(){ | ||
if use php_targets_php5-6 ; then | ||
php-ext-source-r3_src_prepare | ||
else | ||
default_src_prepare | ||
fi | ||
} | ||
|
||
src_configure() { | ||
local PHP_EXT_ECONF_ARGS="--enable-memcached | ||
$(use_enable session memcached-session) | ||
$(use_enable sasl memcached-sasl) | ||
$(use_enable json memcached-json) | ||
$(use_enable igbinary memcached-igbinary)" | ||
|
||
php-ext-source-r3_src_configure | ||
} | ||
|
||
src_install() { | ||
if use php_targets_php5-6 ; then | ||
php-ext-pecl-r3_src_install | ||
fi | ||
} |
65 changes: 65 additions & 0 deletions
65
dev-php/pecl-memcached/pecl-memcached-3.0.0_alpha1_pre20161206.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,65 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PHP_EXT_NAME="memcached" | ||
PHP_EXT_INI="yes" | ||
PHP_EXT_ZENDEXT="no" | ||
DOCS=( ChangeLog README.markdown ) | ||
|
||
USE_PHP="php5-6 php7-0 php7-1" | ||
|
||
inherit php-ext-source-r3 vcs-snapshot | ||
|
||
USE_PHP="php7-0" | ||
|
||
SRC_URI="https://github.com/php-memcached-dev/php-memcached/archive/e65be324557eda7167c4831b4bfb1ad23a152beb.tar.gz -> ${P}.tar.gz" | ||
HOMEPAGE="http://pecl.php.net/package/memcached" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
DESCRIPTION="Interface PHP with memcached via libmemcached library" | ||
LICENSE="PHP-3" | ||
SLOT="7" | ||
IUSE="+session igbinary json sasl" | ||
|
||
COMMON_DEPEND=">=dev-libs/libmemcached-1.0.14[sasl?] | ||
sys-libs/zlib | ||
igbinary? ( dev-php/igbinary[php_targets_php7-0?] )" | ||
|
||
DEPEND="php_targets_php7-0? ( ${COMMON_DEPEND} dev-lang/php:7.0[session?,json?] ) | ||
php_targets_php7-1? ( ${COMMON_DEPEND} dev-lang/php:7.1[session?,json?] )" | ||
RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-memcached:0[php_targets_php5-6] )" | ||
|
||
src_unpack(){ | ||
if use php_targets_php7-0 || use php_targest_php7-1 ; then | ||
vcs-snapshot_src_unpack | ||
php-ext-source-r3_src_unpack | ||
else | ||
S="${WORKDIR}" | ||
fi | ||
} | ||
|
||
src_prepare(){ | ||
if use php_targets_php7-0 || use php_targets_php7-1 ; then | ||
php-ext-source-r3_src_prepare | ||
else | ||
default_src_prepare | ||
fi | ||
} | ||
|
||
src_configure() { | ||
local PHP_EXT_ECONF_ARGS="--enable-memcached | ||
$(use_enable session memcached-session) | ||
$(use_enable sasl memcached-sasl) | ||
$(use_enable json memcached-json) | ||
$(use_enable igbinary memcached-igbinary)" | ||
|
||
php-ext-source-r3_src_configure | ||
} | ||
|
||
src_install(){ | ||
if use php_targets_php7-0 || use php_targets_php7-1 ; then | ||
php-ext-source-r3_src_install | ||
fi | ||
} |