Skip to content

Commit

Permalink
sys-apps/sandbox: Version bump
Browse files Browse the repository at this point in the history
No keywords yet, please test.

Bug: https://bugs.gentoo.org/672918
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Andreas K. Hüttel <[email protected]>
  • Loading branch information
akhuettel committed Mar 10, 2019
1 parent 9d6a8a1 commit 3446bb7
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-apps/sandbox/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST sandbox-2.12.tar.xz 424252 BLAKE2B 55eb06cbc15ad9ff8b0c272b8d071591ce3533a6
DIST sandbox-2.13.tar.xz 424968 BLAKE2B efcbf527853e8cfe8b3fec026041f55f51cba78029f92195ec76a45e84cb2b6cc129267c6e50608584607de72a86b2e7836e77f20677de9b94bb5c40999e4712 SHA512 46ad79335e51a1ec0aaa34ab5eeabe9d007818c518682409c5aaf97d49ec23021ece8fa53264ce5332cdd04ef6b3fd9beff0dc0a3cb5dfe2f9b6a6e359f8c1cf
DIST sandbox-2.14.tar.xz 426992 BLAKE2B a30984f613b773cb5e53b2b0297ada32d11797699418aebf3014e11f3ec2b69a1c4b4e22ce96c28b1df022617cab6787cfe61f84b37ed61e966ac425eae1c7eb SHA512 b84584cffc54678646798bc58d8b60cdc10a0a58c9f1a49276dcac205a06dd7a2e664d2a9c40c78b48eae8ac36e3ac498ba35674f10e6e06c3c2bab777e05ced
DIST sandbox-2.15.tar.xz 426948 BLAKE2B e40bb728192ef3793a9129bc88a63878516b0977a19effd5b02ded644ec6fe1627fab34786b22024957d96725fc5c53f488f7b09119be7b7ca91692dcee985dc SHA512 7249b594864267311ce8e2c04275df49c6d8e8e811dde5780f7f676cb43928728b9abed77beb8f5ee32061efcdb03753cce44d5bf1827bd519d6be8fa54912e6
DIST sandbox-2.16.tar.xz 431292 BLAKE2B b5c0a5550cec99a22144f0e51d6ca05e3ace4be7ce59760771fd13cf8b578a5928a89a1fe8119832e59762f3e6f2b80f2a98f853148a2c20e5357eb9c7f4b67a SHA512 f883da9bf1cf00f452f7e709bac914aca877c7f990baf4eef90c9cc31d47a5ec7571d13d84269c85e3cd0d0546f828d81fc93169916ad397f98e0af6147733a8
76 changes: 76 additions & 0 deletions sys-apps/sandbox/sandbox-2.16.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit eutils flag-o-matic multilib-minimal multiprocessing pax-utils

DESCRIPTION="sandbox'd LD_PRELOAD hack"
HOMEPAGE="https://www.gentoo.org/proj/en/portage/sandbox/"
SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE=""

DEPEND="app-arch/xz-utils
>=app-misc/pax-utils-0.1.19" #265376
RDEPEND=""

has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"

sandbox_death_notice() {
ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
}

multilib_src_configure() {
filter-lfs-flags #90228

local myconf=()
host-is-pax && myconf+=( --disable-pch ) #301299 #425524 #572092

ECONF_SOURCE="${S}" \
econf "${myconf[@]}"
}

multilib_src_test() {
# Default sandbox build will run with --jobs set to # cpus.
emake check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
}

multilib_src_install_all() {
doenvd "${FILESDIR}"/09sandbox

keepdir /var/log/sandbox
fowners root:portage /var/log/sandbox
fperms 0770 /var/log/sandbox

dodoc AUTHORS ChangeLog* NEWS README
}

pkg_preinst() {
chown root:portage "${ED}"/var/log/sandbox
chmod 0770 "${ED}"/var/log/sandbox

local v
for v in ${REPLACING_VERSIONS}; do
if [[ ${v} == 1.* ]] ; then
local old=$(find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*')
if [[ -n ${old} ]] ; then
elog "Removing old sandbox libraries for you:"
find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*' -print -delete
fi
fi
done
}

pkg_postinst() {
local v
for v in ${REPLACING_VERSIONS}; do
if [[ ${v} == 1.* ]] ; then
chmod 0755 "${EROOT}"/etc/sandbox.d #265376
fi
done
}

0 comments on commit 3446bb7

Please sign in to comment.