Skip to content

Commit

Permalink
dev-python/botocore: Bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
patricklauer committed Dec 24, 2017
1 parent 2fb2a14 commit 344ab35
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/botocore/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -7,4 +7,5 @@ DIST botocore-1.5.90.tar.gz 3707524 BLAKE2B 8509594072f0c220a388b97641726a8e2a69
DIST botocore-1.5.95.tar.gz 3712795 BLAKE2B 1c9b88e144aabea907919dbf1387f46b1a1a45db57c1f8cb5a7c48c23c43927afb517ccefb70da1b18465bc407332a775452cbade0d7fd5fbfb38103bc4070d0 SHA512 872fac30476e3f05fa065ea2963b2221046d0eb7cd91267b0f9209fcd05b81b29eba99c439ad220a81c98a880b4087d961667d8a27c560cd9ba4481b8bc703c9
DIST botocore-1.6.8.tar.gz 3769332 BLAKE2B 21623cf7d8fe3dba1a87698b89f3bfcbed161f7d06e3ef02a2bbf117280945a860ce5cd309987ef3eab24441facb8952c8bf7e7e9f2eddf1697791b95c0e6e59 SHA512 2565127620793eb94ef817a4295af3484aa7f30268fa915d37b82c5dc240ae2d74eea60bf68bdaf3d180648ff4225455e9453d75454d5a6d5ffadd19f2a2bd05
DIST botocore-1.7.39.tar.gz 3838231 BLAKE2B 53355a6f0fca131db8ae41ff7e0b5405dc2a4c1a0630743ec34e0fabe60468d27ea9d36b67dc3b8757c3f524eabf3fef1e55d3eb0df1f4c5bd229448f8dfc3d4 SHA512 0a6031315356f43e00ba5661020890478a589f0524bacd22fd24a9f8da147761f70d7b7fae9aab887301e78a392bc12dc7067174af9a07aac346d11a4cec9a22
DIST botocore-1.8.20.tar.gz 4173990 BLAKE2B ce9813c77b440fdfd123593aeb9f5c47bec877981dad5089b83633deebab3bf4aed76c13ac73f571eeb8349406b3f04e6c33634a865e076ffdca266cf418b80c SHA512 0b822bff75ef26c7e996e354a5c06cb50eb13d7e58f65297adcf023a81084c8b98500c08b906dcfd346e2dadcdde33d472d6d51c3e081af8667c5adcdd2deffd
DIST botocore-1.8.6.tar.gz 4142560 BLAKE2B 2350f448b9e11ef1f65aa6b9dea3cdd57fd2ad74e2d73e716a5b77478fec925b69cf283f64c37226d11b8e91486a523ed4bf2c68c886b97b5e9129fbdbc1ba42 SHA512 5d91033aa81dee1d3115f4db32c1d8f892324f96ef5233f29d35f43a9a9d2ea4adc58d1a2d66eeeb0bb7332904a29398e31b91a486bea71552ed1d0246e8f804
56 changes: 56 additions & 0 deletions dev-python/botocore/botocore-1.8.20.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )

inherit distutils-r1

DESCRIPTION="Low-level, data-driven core of boto 3."
HOMEPAGE="https://github.com/boto/botocore"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"

CDEPEND="
>=dev-python/docutils-0.10[${PYTHON_USEDEP}]
>=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
<dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
<dev-python/python-dateutil-3.0.0[${PYTHON_USEDEP}]
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
>=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
<dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
<dev-python/sphinx-1.7[${PYTHON_USEDEP}]
)
test? (
${CDEPEND}
~dev-python/mock-1.3.0[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
)
"
RDEPEND="${CDEPEND}"

PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )

python_compile_all() {
use doc && emake -C docs html
}

python_test() {
PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( docs/build/html/. )

distutils-r1_python_install_all
}

0 comments on commit 344ab35

Please sign in to comment.