Skip to content

Commit

Permalink
dev-vcs/tig: version bump to 2.2.1
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Nov 25, 2016
1 parent fbe96ab commit 34559cf
Show file tree
Hide file tree
Showing 3 changed files with 60 additions and 2 deletions.
1 change: 1 addition & 0 deletions dev-vcs/tig/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST tig-2.1.1.tar.gz 641710 SHA256 50c5179fd564b829b6b2cec087e66f10cf8799601de19350df0772ae77e4852f SHA512 be55ece813e1af938e3c4d805d4f034e78f75c1fcda7f4b5bc02de8b228d6d76b9f4921f6dc079485b8c13a3acc5ea2d146a0c437d28add45d50137ae6545f10 WHIRLPOOL 869012b9e5d47eaa24d7939202819bcf85c44ed4d2de742d7770d8610f3e86dfae43588f626de2785f10e78293c21151272b81b0f196163844ea8b76cce5d01c
DIST tig-2.2.1.tar.gz 1028479 SHA256 0b48080896de59179c45c980080b4b414bb235df65ad08d661a9c9e169c3fa71 SHA512 6e483a400e222c01a4f518ee473b8d37933e820a2da1fc2cfe0ae9fb8217867d16f1aee3deecb14ce9af6a6dd2814d709d6ffce5f1f5054b94d2ab533b47008b WHIRLPOOL a4bcb381f81d07d92623a38c3ed5a78321043a776f0e4cb44e0f736cf960b01d2599b90f7a7f9056d0e0388ecd8112f25aed1b162c9b629c4bf9d10eaa98ebb7
DIST tig-2.2.tar.gz 1030062 SHA256 8f5213d3abb45ca9a79810b8d2a2a12d941112bc4682bcfa91f34db74942754c SHA512 53b85a1309becc7a72e915801ef9412de113f3d113ab0e3915c77999b86a58f4144f267cd3a6c47af8229e00b6146d5e6c38a591077dd746a5f0518b6a50ceae WHIRLPOOL 036cb1a2b66f8f4975b98f6dae049be014868c7508802858f7024b1c0518e8a8afc49181808a7fd4f941e44e4b79032333a30d612d74618fbef17d541e98edd6
57 changes: 57 additions & 0 deletions dev-vcs/tig/tig-2.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit bash-completion-r1

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/jonas/tig.git"
inherit git-r3 autotools
else
SRC_URI="https://github.com/jonas/tig/releases/download/${P}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
fi

DESCRIPTION="text mode interface for git"
HOMEPAGE="https://jonas.github.io/tig/"

LICENSE="GPL-2"
SLOT="0"
IUSE="unicode"

DEPEND="
sys-libs/ncurses:0=[unicode?]
sys-libs/readline:0="
RDEPEND="${DEPEND}
dev-vcs/git"
[[ ${PV} == "9999" ]] && DEPEND+=" app-text/asciidoc"

src_prepare() {
default
[[ ${PV} == "9999" ]] && eautoreconf
}

src_configure() {
econf $(use_with unicode ncursesw)
}

src_compile() {
emake V=1
[[ ${PV} == "9999" ]] && emake V=1 doc-man doc-html
}

src_test() {
# workaround parallel test failures
emake -j1 test
}

src_install() {
emake DESTDIR="${D}" install install-doc-man
dodoc doc/manual.html README.html NEWS.html
newbashcomp contrib/tig-completion.bash ${PN}

docinto examples
dodoc contrib/*.tigrc
}
4 changes: 2 additions & 2 deletions dev-vcs/tig/tig-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -10,12 +10,12 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/jonas/tig.git"
inherit git-r3 autotools
else
SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
SRC_URI="https://github.com/jonas/tig/releases/download/${P}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
fi

DESCRIPTION="text mode interface for git"
HOMEPAGE="http://jonas.nitro.dk/tig/"
HOMEPAGE="https://jonas.github.io/tig/"

LICENSE="GPL-2"
SLOT="0"
Expand Down

0 comments on commit 34559cf

Please sign in to comment.