forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
69 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST botocore-1.33.11.gh.tar.gz 12536159 BLAKE2B bce09ad1b93210667e3c1058ab3b4350b752e330c78c29af87c53b3f3f738dd7622b1b670a4fdbfa2dfdeaf763f9885b3f82ad0eb4f44c7e7585ae5b8eaa6b5d SHA512 5d790bbb909230861cf2eb38908f5876ab9bd7e5dd1f718987797af0b263c7ea2c42d69aa1d55b66d1b954204caa04c50cd050385607637192e9ad6b33f65b7d | ||
DIST botocore-1.33.6.gh.tar.gz 12516087 BLAKE2B da3ca22acb5b6ee27eb3c0f7dab4ad43597ab985aa7512f4f4a51c2ca3db80a049e13faaf986dd4a02125f92c088129506651125a826184656250665dc7b7128 SHA512 cae5019d85c9b3afcfd93fe58d0e51c5a6e0769d58b2a8b1285a34ce66be8db34e9c5dc4dc74ff72e0992cdd142d101e3663fa1d68a2779fa9c09de37d2f2001 | ||
DIST botocore-1.34.1.gh.tar.gz 12561522 BLAKE2B 67b42866c4a00ea960b8d942110acdf9fd642e9164c987e12f9e12ceee37b1c4d9be59a3185006c19b52c31b957442fe4fa9de9d4d1d697854c0c1c7b9eb23cc SHA512 04cba828baf7bb14f2cb2a3eedca6332842ca1d0c8d1e5ad837607ea6c5fe1564a222c516835d7f67e2fea85490032ef04d61d631c0cff6849ee7cdca5eeabf4 | ||
DIST botocore-1.34.2.gh.tar.gz 12564834 BLAKE2B b22a3d3bd35b769a28ccb1a5116428e1904d0c9fc3452829237704dbec37a31a539f044a728b0785d09406d299d522dd601da39801249747d54e6741b46cafe2 SHA512 a3f3718bf584a871abbb3edc803de9d5329da257c050d56bdbf8a6a6c4067477812582fbd8d1d789ce18ea1f416d0ddb2be9cc3c45172292d061a94a12f3977b |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,68 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=setuptools | ||
PYTHON_COMPAT=( python3_{10..12} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Low-level, data-driven core of boto 3" | ||
HOMEPAGE=" | ||
https://github.com/boto/botocore/ | ||
https://pypi.org/project/botocore/ | ||
" | ||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
|
||
if [[ "${PV}" == "9999" ]]; then | ||
EGIT_REPO_URI="https://github.com/boto/botocore" | ||
inherit git-r3 | ||
else | ||
SRC_URI=" | ||
https://github.com/boto/botocore/archive/${PV}.tar.gz | ||
-> ${P}.gh.tar.gz | ||
" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux" | ||
fi | ||
|
||
RDEPEND=" | ||
dev-python/six[${PYTHON_USEDEP}] | ||
<dev-python/jmespath-2[${PYTHON_USEDEP}] | ||
dev-python/python-dateutil[${PYTHON_USEDEP}] | ||
>=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}] | ||
" | ||
BDEPEND=" | ||
test? ( | ||
dev-python/jsonschema[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
EPYTEST_XDIST=1 | ||
distutils_enable_tests pytest | ||
|
||
src_prepare() { | ||
# unpin deps | ||
sed -i -e "s:>=.*':':" setup.py || die | ||
|
||
# unbundle deps | ||
rm -r botocore/vendored || die | ||
find -name '*.py' -exec sed -i \ | ||
-e 's:from botocore[.]vendored import:import:' \ | ||
-e 's:from botocore[.]vendored[.]:from :' \ | ||
{} + || die | ||
|
||
distutils-r1_src_prepare | ||
} | ||
|
||
python_test() { | ||
local EPYTEST_DESELECT=( | ||
# rely on bundled six | ||
tests/functional/test_six_imports.py::test_no_bare_six_imports | ||
tests/functional/test_six_threading.py::test_six_thread_safety | ||
) | ||
|
||
local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1 | ||
epytest tests/{functional,unit} | ||
} |